summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMichel Zou <[email protected]>2019-11-17 16:40:29 +0100
committerEric Engestrom <[email protected]>2019-11-23 16:09:52 +0000
commit95fdde5a60fc04376eb49a1d62ead163516759f3 (patch)
tree6e9c91b50e0c4c6c2bf6305af777700b6bdc38e1 /meson.build
parent02d63ee5a44635692fcec620563f7416f21732c8 (diff)
Meson: Add llvm>=9 modules
Fixes build with MinGW, with shared LLVM and lto /tmp/opengl32.dll.BxiIYm.ltrans59.ltrans.o:<artificial>:(.text+0x1674): undefined reference to `LLVMAddInstructionCombiningPass' See also scons/llvm.py Acked-by: Dylan Baker <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 69d15649060..9585807fbee 100644
--- a/meson.build
+++ b/meson.build
@@ -1356,7 +1356,7 @@ if dep_libdrm.found()
endif
endif
-llvm_modules = ['bitwriter', 'engine', 'mcdisassembler', 'mcjit']
+llvm_modules = ['bitwriter', 'engine', 'mcdisassembler', 'mcjit', 'core', 'executionengine', 'scalaropts', 'transformutils', 'instcombine']
llvm_optional_modules = ['coroutines']
if with_amd_vk or with_gallium_radeonsi or with_gallium_r600
llvm_modules += ['amdgpu', 'native', 'bitreader', 'ipo']