summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2019-10-11 09:19:25 -0700
committerDylan Baker <[email protected]>2019-10-16 23:26:09 +0000
commit4441da00448df0700e4424900091ebbdaa6a3c4f (patch)
tree08e06a51496db4337cec25ec22d6367f6c5dc92b /meson.build
parent656c038d010b1cc82e0944f4c0fca85ece769bfb (diff)
meson: Don't use expat on windows
It's not really needed, and there's no debian package for it so we're forced to fall back to wraps in mesa's CI. This can be problematic in itself. Reviewed-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index e65dcf482aa..ac52833f417 100644
--- a/meson.build
+++ b/meson.build
@@ -1265,7 +1265,11 @@ if dep_thread.found() and host_machine.system() != 'windows'
pre_args += '-DPTHREAD_SETAFFINITY_IN_NP_HEADER'
endif
endif
-dep_expat = dependency('expat', fallback : ['expat', 'expat_dep'])
+if host_machine.system() != 'windows'
+ dep_expat = dependency('expat', fallback : ['expat', 'expat_dep'])
+else
+ dep_expat = null_dep
+endif
# this only exists on linux so either this is linux and it will be found, or
# it's not linux and wont
dep_m = cc.find_library('m', required : false)