summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorKai Wasserbäch <[email protected]>2019-08-17 10:59:43 +0200
committerDave Airlie <[email protected]>2019-08-20 05:39:19 +0000
commit1abe87383e1529a14498d70a0cf445728b9c338d (patch)
treefaa347aadfdd04dbbf513d77dc66412453d8d8fc /meson.build
parentd0ec5d38f6cff2e61d9e526423c0a016cc830d14 (diff)
build: Bump C++ standard requirement to C++14 to fix FTBFS with LLVM 10
When building Mesa against a recent LLVM 10 with C++11, the build fails if the AMD common code is built as well due to "std::index_sequence" being undeclared. LLVM requires a minimum of C++14. Signed-off-by: Kai Wasserbäch <[email protected]> Acked-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index ea9dca71afc..bf61511d292 100644
--- a/meson.build
+++ b/meson.build
@@ -26,7 +26,7 @@ project(
).stdout(),
license : 'MIT',
meson_version : '>= 0.46',
- default_options : ['buildtype=debugoptimized', 'b_ndebug=if-release', 'c_std=c99', 'cpp_std=c++11']
+ default_options : ['buildtype=debugoptimized', 'b_ndebug=if-release', 'c_std=c99', 'cpp_std=c++14']
)
cc = meson.get_compiler('c')