summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorJulien Cristau <[email protected]>2007-04-21 20:47:01 +0200
committerJulien Cristau <[email protected]>2007-04-21 20:47:01 +0200
commitd79e80a3d0597444528251d7d9362b2a6eab187c (patch)
tree6bedb0bb0cae9bc85557a6112fad962adf605245 /debian
parentd890ebdd2591c5c09038c8986341da17127ba930 (diff)
New upstream release candidate.
Drop patches included upstream.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog9
-rw-r--r--debian/patches/06_fix_texture_data_corruption.patch23
-rw-r--r--debian/patches/07_call_radeonSetCliprects_from_radeonMakeCurrent.patch56
-rw-r--r--debian/patches/08_r300_update_window_state_when_bound_but_stamp_changed.patch35
-rw-r--r--debian/patches/09_i915_always_enable_pixel_fog.patch31
-rw-r--r--debian/patches/series4
6 files changed, 8 insertions, 150 deletions
diff --git a/debian/changelog b/debian/changelog
index 4d0e3bfe251..d038f8d825c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,7 +5,14 @@ mesa (6.5.3~rc1-1) UNRELEASED; urgency=low
static and shared libraries, creating libglw1-mesa and libglw1-mesa-dev
(closes: #374904).
- -- Brice Goglin <[email protected]> Fri, 30 Mar 2007 19:44:53 +0200
+ [ Julien Cristau ]
+ * New upstream release candidate.
+ + 06_fix_texture_data_corruption.patch,
+ 07_call_radeonSetCliprects_from_radeonMakeCurrent.patch,
+ 08_r300_update_window_state_when_bound_but_stamp_changed.patch,
+ 09_i915_always_enable_pixel_fog.patch: remove, included upstream.
+
+ -- Julien Cristau <[email protected]> Sat, 21 Apr 2007 20:43:43 +0200
mesa (6.5.2-5) UNRELEASED; urgency=low
diff --git a/debian/patches/06_fix_texture_data_corruption.patch b/debian/patches/06_fix_texture_data_corruption.patch
deleted file mode 100644
index 5bca17af5a4..00000000000
--- a/debian/patches/06_fix_texture_data_corruption.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From: Michel Dänzer <[email protected]>
-Date: Thu, 14 Dec 2006 09:01:43 +0000 (+0100)
-Subject: _mesa_swizzle_ubyte_image: Only use single swizzle_copy call when strides match.
-X-Git-Url: http://gitweb.freedesktop.org/?p=mesa/mesa.git;a=commitdiff;h=9c09259b8bef8f120cc6f4bb1a44f0eae37d71b3
-
-_mesa_swizzle_ubyte_image: Only use single swizzle_copy call when strides match.
-
-This fixes texture data corruption with glTexSubimage (and probably glTexImage
-under some circumstances) with the texstore swizzle path.
----
-
---- a/src/mesa/main/texstore.c
-+++ b/src/mesa/main/texstore.c
-@@ -808,7 +808,8 @@ _mesa_swizzle_ubyte_image(GLcontext *ctx
-
- /* _mesa_printf("map %d %d %d %d\n", map[0], map[1], map[2], map[3]); */
-
-- if (srcRowStride == srcWidth * srcComponents &&
-+ if (srcRowStride == dstRowStride &&
-+ srcRowStride == srcWidth * srcComponents &&
- dimensions < 3) {
- /* 1 and 2D images only */
- GLubyte *dstImage = (GLubyte *) dstAddr
diff --git a/debian/patches/07_call_radeonSetCliprects_from_radeonMakeCurrent.patch b/debian/patches/07_call_radeonSetCliprects_from_radeonMakeCurrent.patch
deleted file mode 100644
index 08f8f70bf9f..00000000000
--- a/debian/patches/07_call_radeonSetCliprects_from_radeonMakeCurrent.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-From: Michel Dänzer <[email protected]>
-Date: Tue, 6 Mar 2007 12:22:35 +0000 (+0100)
-Subject: r300: Call radeonSetCliprects from radeonMakeCurrent.
-X-Git-Url: http://gitweb.freedesktop.org/?p=mesa/mesa.git;a=commitdiff;h=6f9b1afc862851532e4820705c412388b497ad58
-
-r300: Call radeonSetCliprects from radeonMakeCurrent.
-
-Based on a patch by Panagiotis Papadakos.
-
-Among other things, this makes sure the framebuffer object associated with the
-drawable has the correct size when _mesa_make_current is called, so the default
-viewport is set up correctly.
-
-Also update radeon->lastStamp in radeonSetCliprects.
----
-
---- a/src/mesa/drivers/dri/r300/radeon_context.c
-+++ b/src/mesa/drivers/dri/r300/radeon_context.c
-@@ -51,6 +51,7 @@ WITH THE SOFTWARE OR THE USE OR OTHER DE
- #include "radeon_macros.h"
- #include "radeon_reg.h"
-
-+#include "radeon_state.h"
- #include "r300_state.h"
-
- #include "utils.h"
-@@ -279,6 +280,8 @@ GLboolean radeonMakeCurrent(__DRIcontext
-
- r300UpdateWindow(radeon->glCtx);
- r300UpdateViewportOffset(radeon->glCtx);
-+
-+ radeonSetCliprects(radeon);
- }
-
- _mesa_make_current(radeon->glCtx,
---- a/src/mesa/drivers/dri/r300/radeon_lock.c
-+++ b/src/mesa/drivers/dri/r300/radeon_lock.c
-@@ -90,7 +90,6 @@ static void r300RegainedLock(radeonConte
- #else
- radeonUpdateScissor(radeon->glCtx);
- #endif
-- radeon->lastStamp = drawable->lastStamp;
- }
-
- if (sarea->ctx_owner != radeon->dri.hwContext) {
---- a/src/mesa/drivers/dri/r300/radeon_state.c
-+++ b/src/mesa/drivers/dri/r300/radeon_state.c
-@@ -185,6 +185,8 @@ void radeonSetCliprects(radeonContextPtr
-
- if (radeon->state.scissor.enabled)
- radeonRecalcScissorRects(radeon);
-+
-+ radeon->lastStamp = drawable->lastStamp;
- }
-
-
diff --git a/debian/patches/08_r300_update_window_state_when_bound_but_stamp_changed.patch b/debian/patches/08_r300_update_window_state_when_bound_but_stamp_changed.patch
deleted file mode 100644
index 8bf8db683f6..00000000000
--- a/debian/patches/08_r300_update_window_state_when_bound_but_stamp_changed.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From: Michel Dänzer <[email protected]>
-Date: Fri, 9 Mar 2007 08:43:17 +0000 (+0100)
-Subject: r300: Also update window state when it's already bound but its stamp changed.
-X-Git-Url: http://gitweb.freedesktop.org/?p=mesa/mesa.git;a=commitdiff;h=4d9901a1cab8e0d55b1b2309cf3ffec235e53149
-
-r300: Also update window state when it's already bound but its stamp changed.
-
-And set new cliprects before deriving other state from them. This ensures
-cliprects aren't accessed after having been freed.
-
-Thanks to Panagiotis Papadakos for testing various iterations of this.
----
-
---- a/src/mesa/drivers/dri/r300/radeon_context.c
-+++ b/src/mesa/drivers/dri/r300/radeon_context.c
-@@ -273,15 +273,15 @@ GLboolean radeonMakeCurrent(__DRIcontext
- &radeon->vbl_seq);
- }
-
-+ radeon->dri.readable = driReadPriv;
-+
- if (radeon->dri.drawable != driDrawPriv ||
-- radeon->dri.readable != driReadPriv) {
-+ radeon->lastStamp != driDrawPriv->lastStamp) {
- radeon->dri.drawable = driDrawPriv;
-- radeon->dri.readable = driReadPriv;
-
-+ radeonSetCliprects(radeon);
- r300UpdateWindow(radeon->glCtx);
- r300UpdateViewportOffset(radeon->glCtx);
--
-- radeonSetCliprects(radeon);
- }
-
- _mesa_make_current(radeon->glCtx,
diff --git a/debian/patches/09_i915_always_enable_pixel_fog.patch b/debian/patches/09_i915_always_enable_pixel_fog.patch
deleted file mode 100644
index d1056487051..00000000000
--- a/debian/patches/09_i915_always_enable_pixel_fog.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From: Zou Nan hai <[email protected]>
-Date: Fri, 2 Feb 2007 01:35:17 +0000 (+0800)
-Subject: Fix fd.o #9686, when fall into vertex fog,
-X-Git-Url: http://gitweb.freedesktop.org/?p=mesa/mesa.git;a=commitdiff;h=2dfb3a217f730d6783fb2ac8b73248dc682f923c
-
- Fix fd.o #9686, when fall into vertex fog,
- fog factors are precomputed in t_vb_fog.c compute_fog_blend_factors,
- which is incompatible with appended fragment fog code.
- That will make GoogleEarth display abnormally.
- always use pixel fog.
----
-
---- a/src/mesa/drivers/dri/i915/i915_state.c
-+++ b/src/mesa/drivers/dri/i915/i915_state.c
-@@ -611,10 +611,12 @@ void i915_update_fog( GLcontext *ctx )
- i915->state.Ctx[I915_CTXREG_LIS5] &= ~S5_FOG_ENABLE;
- }
-
-- if (enabled) {
-- _tnl_allow_vertex_fog( ctx, (i915->vertex_fog == I915_FOG_VERTEX) );
-- _tnl_allow_pixel_fog( ctx, (i915->vertex_fog != I915_FOG_VERTEX) );
-- }
-+ /* always enbale pixel fog
-+ * vertex fog use precaculted fog coord will conflict with appended
-+ * fog program
-+ */
-+ _tnl_allow_vertex_fog( ctx, 0 );
-+ _tnl_allow_pixel_fog( ctx, 1 );
- }
-
- static void i915Fogfv(GLcontext *ctx, GLenum pname, const GLfloat *param)
diff --git a/debian/patches/series b/debian/patches/series
index f8249980eff..280a2f3548e 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -4,7 +4,3 @@
03_optional-progs-and-install.patch
04_cleanup-osmesa-configs.patch
05_static-nonpic.patch
-06_fix_texture_data_corruption.patch
-07_call_radeonSetCliprects_from_radeonMakeCurrent.patch
-08_r300_update_window_state_when_bound_but_stamp_changed.patch
-09_i915_always_enable_pixel_fog.patch