summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorJulien Cristau <[email protected]>2007-04-23 11:00:09 +0200
committerJulien Cristau <[email protected]>2007-04-23 11:00:09 +0200
commit4adbd94b100b4bf94e7016691fe9dcd71e8637d9 (patch)
tree6cebf446ca6f0bb1b76ab582ac59fb62e21c8669 /debian
parent4a2905b645b15a07a5c1c3f26af22039798c2492 (diff)
Only install stuff in mesa-swx11-source if we're building arch:all packages.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog3
-rwxr-xr-xdebian/rules12
2 files changed, 8 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index babaccaf87e..cf425d3105a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -13,8 +13,9 @@ mesa (6.5.3~rc2-1) UNRELEASED; urgency=low
09_i915_always_enable_pixel_fog.patch: remove, included upstream.
* Add build-dependencies on libxdamage-dev and libxfixes-dev.
* Resync debian/scripts/install-source.sh.
+ * Build mesa-swx11-source only in binary-indep.
- -- Julien Cristau <[email protected]> Sun, 22 Apr 2007 00:50:43 +0200
+ -- Julien Cristau <[email protected]> Sun, 22 Apr 2007 01:06:39 +0200
mesa (6.5.2-5) UNRELEASED; urgency=low
diff --git a/debian/rules b/debian/rules
index 7a7025f1f0c..3d00bb72401 100755
--- a/debian/rules
+++ b/debian/rules
@@ -44,8 +44,8 @@ CONFIGS = $(SWX11_GLU_CONFIGS) \
STAMP = $(STAMP_DIR)/$(DEB_BUILD_GNU_TYPE)
BUILD_STAMPS = $(addprefix $(STAMP)-build-, $(CONFIGS))
-INSTALL_STAMPS = $(addprefix $(STAMP)-install-, $(CONFIGS)) \
- $(STAMP_DIR)/install-source
+ARCH_INSTALL_STAMPS = $(addprefix $(STAMP)-install-, $(CONFIGS))
+INDEP_INSTALL_STAMPS = $(STAMP_DIR)/install-source
# list the configurations that will built
configs:
@@ -72,17 +72,17 @@ $(STAMP)-build-%: patch
pre-install:
dh_testdir
dh_testroot
- dh_clean -k --exclude ./Makefile.orig --exclude configs/CVS/Root.bak
+ dh_clean -k
rm -rf $(INSTALL_STAMPS)
-install: pre-install $(INSTALL_STAMPS)
+install: pre-install $(ARCH_INSTALL_STAMPS)
$(STAMP)-install-%: $(STAMP)-build-%
# Add here commands to install the package into debian/tmp
cd $(DEB_BUILD_DIR)/$* && $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
touch $@
-$(STAMP_DIR)/install-source:
+$(STAMP_DIR)/install-source: pre-install
# install Mesa source for mesa-swx11-source package
chmod a+x debian/scripts/install-source.sh
debian/scripts/install-source.sh
@@ -95,7 +95,7 @@ clean: unpatch
rm -rf $(DEB_BUILD_DIR) $(STAMP_DIR)
# Build architecture-independent files here.
-binary-indep: build install
+binary-indep: build install $(INDEP_INSTALL_STAMPS)
dh_testdir
dh_testroot
dh_installchangelogs -i