summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorThierry Reding <[email protected]>2006-10-15 13:15:56 +0000
committerThierry Reding <[email protected]>2006-10-15 13:15:56 +0000
commit8ef731bcd11af50e92fc1356532df44a80f7a4b0 (patch)
treea49e9e0b7ef5811b8671415f2a2dad6684fcc267 /debian
parent8d02f3c68a1852de6bfe8c0b58c325224fef9743 (diff)
Add a patch (00_create-libdir) that fixes the upstream build system to make
sure the LIB_DIR is created or bail out. Update the 01_fix-makefile patch to only install libGL/libOSMesa if they exist. Don't make installation dependent on which drivers are built. Build optimized versions of the swx11 libraries in addition to those that should work on the least-capable supported processor for the given architecture. Have most configurations include debian-default instead of debian-common so that INSTALL_DIR is correctly defined. debian-common can probably be dropped anyway.
Diffstat (limited to 'debian')
-rw-r--r--debian/libgl1-mesa-dri.install2
-rw-r--r--debian/libgl1-mesa-glx.install2
-rw-r--r--debian/patches/00_create-libdir.patch11
-rw-r--r--debian/patches/01_fix-makefile.patch7
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules9
6 files changed, 25 insertions, 7 deletions
diff --git a/debian/libgl1-mesa-dri.install b/debian/libgl1-mesa-dri.install
index f3e8ada53ac..55500c81209 100644
--- a/debian/libgl1-mesa-dri.install
+++ b/debian/libgl1-mesa-dri.install
@@ -1 +1 @@
-usr/libglx/dri/*.so usr/lib/dri
+usr/lib/dri/*.so
diff --git a/debian/libgl1-mesa-glx.install b/debian/libgl1-mesa-glx.install
index 270e569baa4..1a30ecd7cbd 100644
--- a/debian/libgl1-mesa-glx.install
+++ b/debian/libgl1-mesa-glx.install
@@ -1 +1 @@
-usr/libglx/libGL.so.* usr/lib
+usr/lib/glx/libGL.so.* usr/lib
diff --git a/debian/patches/00_create-libdir.patch b/debian/patches/00_create-libdir.patch
new file mode 100644
index 00000000000..99f02f7bdc1
--- /dev/null
+++ b/debian/patches/00_create-libdir.patch
@@ -0,0 +1,11 @@
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -29,7 +29,7 @@
+ done
+
+ $(TOP)/$(LIB_DIR):
+- -mkdir $(TOP)/$(LIB_DIR)
++ mkdir -p $(TOP)/$(LIB_DIR)
+
+
+ clean:
diff --git a/debian/patches/01_fix-makefile.patch b/debian/patches/01_fix-makefile.patch
index f013c46e1c0..6f8ea18c658 100644
--- a/debian/patches/01_fix-makefile.patch
+++ b/debian/patches/01_fix-makefile.patch
@@ -1,13 +1,14 @@
--- a/src/mesa/Makefile
+++ b/src/mesa/Makefile
-@@ -154,7 +154,11 @@
+@@ -154,7 +154,12 @@
$(INSTALL) -d $(INSTALL_DIR)/include/GL
$(INSTALL) -d $(INSTALL_DIR)/$(LIB_DIR)
$(INSTALL) -m 644 $(TOP)/include/GL/*.h $(INSTALL_DIR)/include/GL
- $(COPY_LIBS) $(TOP)/$(LIB_DIR)/libGL.* $(INSTALL_DIR)/$(LIB_DIR)
-+ @if [ "${DRIVER_DIRS}" != "osmesa" ]; then \
++ @if [ -e $(TOP)/$(LIB_DIR)/$(GL_LIB_NAME) ]; then \
+ $(COPY_LIBS) $(TOP)/$(LIB_DIR)/lib$(GL_LIB).* $(INSTALL_DIR)/$(LIB_DIR); \
-+ else \
++ fi
++ @if [ -e $(TOP)/$(LIB_DIR)/$(OSMESA_LIB_NAME) ]; then \
+ $(COPY_LIBS) $(TOP)/$(LIB_DIR)/lib$(OSMESA_LIB).* $(INSTALL_DIR)/$(LIB_DIR); \
+ fi
@if [ "${DRIVER_DIRS}" = "dri" ] ; then \
diff --git a/debian/patches/series b/debian/patches/series
index 6840f95c944..9616a12dfdc 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
+00_create-libdir.patch
01_fix-makefile.patch
diff --git a/debian/rules b/debian/rules
index 966d25ed8b8..e2c8bbb941c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -32,14 +32,19 @@ STAMPDIR = debian/stamp
# build the following configurations
CONFIGS = debian \
+ debian-arch \
debian-dri \
- debian-osmesa \
debian-osmesa16 \
debian-osmesa16-static \
debian-osmesa32 \
debian-osmesa32-static \
debian-static
+# Don't build architecture-dependent DRI drivers (yet) because it's probably
+# not worth the effort. For benchmarking, include the following configuration
+# in the list above.
+#debian-dri-arch
+
STAMP = $(STAMPDIR)/$(DEB_BUILD_GNU_TYPE)
BUILD_STAMPS = $(addprefix $(STAMP)-build-, $(CONFIGS))
INSTALL_STAMPS = $(addprefix $(STAMP)-install-, $(CONFIGS))
@@ -68,7 +73,7 @@ install: build pre-install $(INSTALL_STAMPS)
$(STAMP)-install-%: $(STAMP)-build-%
# Add here commands to install the package into debian/tmp
- cd $(DEB_BUILD_DIR)/$* && $(MAKE) install INSTALL_DIR=$(CURDIR)/debian/tmp/usr
+ cd $(DEB_BUILD_DIR)/$* && $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
touch $@
clean: unpatch