summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorThierry Reding <[email protected]>2006-10-16 08:58:05 +0000
committerThierry Reding <[email protected]>2006-10-16 08:58:05 +0000
commit55cf480c0b017e9ac7b1792cad64d89edcbe83ec (patch)
tree89c18dafaa2bedcc32526e7853406ccc2e946d47 /debian
parent84db6912f0866a2e3e4255001024ec2de78d7d27 (diff)
Drop the libgl1-mesa-swx11-dbg package until there's a decision as to whether
it is really needed. Allow more than one type of optimization libraries to be built for any given architecture. Currently optimization configurations are provided for i386 [i686], alpha [ev5], amd64, powerpc [603], ppc64 and sparc [ultrasparc]. However, only i686 and amd64 are enabled for now for safety. Add the libgl1-mesa-swx11-i686 for i686 optimized libraries. Drop the debian-common configuration because it is no longer used. Don't build libGLU in all configurations, only when needed.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/control37
-rw-r--r--debian/libgl1-mesa-swx11-dbg.install0
-rw-r--r--debian/libgl1-mesa-swx11-i686.install2
-rwxr-xr-xdebian/rules48
5 files changed, 66 insertions, 26 deletions
diff --git a/debian/changelog b/debian/changelog
index c6bfbcafd9e..450e0eecd28 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
mesa (6.5.1-1) unstable; urgency=low
- *
+ * Provide i686 optimized versions in libgl1-mesa-swx11-i686.
+ * No longer provide the libgl1-mesa-swx11-dbg package.
- -- Thierry Reding <[email protected]> Sat, 14 Oct 2006 02:09:50 +0200
+ -- Thierry Reding <[email protected]> Sun, 15 Oct 2006 19:21:13 +0200
diff --git a/debian/control b/debian/control
index a49a763fae5..76b91d4c0c5 100644
--- a/debian/control
+++ b/debian/control
@@ -27,6 +27,30 @@ Description: A free implementation of the OpenGL API -- runtime
.
On Linux, this library is also known as libGL or libGL.so.1.
+Package: libgl1-mesa-swx11-i686
+Section: libs
+Priority: extra
+Architecture: i386
+Pre-Depends: libgl1-mesa-swx11
+Description: A free implementation of the OpenGL API -- i686 optimized runtime
+ Mesa is a 3-D graphics library with an API which is very similar to
+ that of OpenGL. To the extent that Mesa utilizes the OpenGL command
+ syntax or state machine, it is being used with authorization from
+ Silicon Graphics, Inc. However, the author makes no claim that Mesa
+ is in any way a compatible replacement for OpenGL or associated with
+ Silicon Graphics, Inc.
+ .
+ This library provides a pure software rasteriser; it does not provide
+ a direct rendering-capable library, or one which uses GLX. For that,
+ please see libgl1-mesa-glx.
+ .
+ On Linux, this library is also known as libGL or libGL.so.1.
+ .
+ This set of libraries is optimized for i686 machines and will only be used if
+ you are running a 2.6 kernel on an i686 class CPU. This includes Pentium Pro,
+ Pentium II/II/IV, Celeron CPU's and similar class CPU's (including clones
+ such as AMD Athlon/Opteron, VIA C3 Nehemiah, but not VIA C3 Ezla).
+
Package: libgl1-mesa-swx11-dev
Section: libdevel
Architecture: any
@@ -48,19 +72,6 @@ Description: A free implementation of the OpenGL API -- development support file
a direct rendering-capable library, or one which uses GLX. For that,
please see libgl1-mesa-dev.
-Package: libgl1-mesa-swx11-dbg
-Section: libs
-Architecture: any
-Depends: ${shlibs:Depends}
-Conflicts: libgl1-mesa-swrast-dbg
-Replaces: libgl1-mesa-swrast-dbg
-Provides: libgl1-mesa-swrast-dbg
-Description: A free implementation of the OpenGL API -- debugging package
- This package provides a debug-enabled version of the Mesa libraries.
- .
- For a complete description of Mesa, please look at the libgl1-mesa-swx11
- package.
-
Package: libgl1-mesa-glx
Section: libs
Architecture: any
diff --git a/debian/libgl1-mesa-swx11-dbg.install b/debian/libgl1-mesa-swx11-dbg.install
deleted file mode 100644
index e69de29bb2d..00000000000
--- a/debian/libgl1-mesa-swx11-dbg.install
+++ /dev/null
diff --git a/debian/libgl1-mesa-swx11-i686.install b/debian/libgl1-mesa-swx11-i686.install
new file mode 100644
index 00000000000..53b5801a8c2
--- /dev/null
+++ b/debian/libgl1-mesa-swx11-i686.install
@@ -0,0 +1,2 @@
+usr/lib/i686/cmov/libGL.so.*
+usr/lib/i686/cmov/libOSMesa.*
diff --git a/debian/rules b/debian/rules
index b3b1e133ba4..c0b75b16511 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,10 +1,6 @@
#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
+# debian/rules for the Debian mesa package
+# Copyright © 2006 Thierry Reding <[email protected]>
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
@@ -31,8 +27,7 @@ DEB_BUILD_DIR ?= $(CURDIR)/obj-$(DEB_BUILD_GNU_TYPE)
export DEB_BUILD_ARCH
# build the following configurations
-CONFIGS = debian \
- debian-arch \
+CONFIGS = debian-swx11+glu \
debian-dri-arch \
debian-osmesa16 \
debian-osmesa16-static \
@@ -40,6 +35,36 @@ CONFIGS = debian \
debian-osmesa32-static \
debian-static
+# additional configurations optimized for CPU's supported by the build
+# architecture
+ifeq ($(DEB_BUILD_ARCH), i386)
+ CONFIGS += debian-i386-i686
+endif
+
+#ifeq ($(DEB_BUILD_ARCH), alpha)
+# CONFIGS += debian-alpha-ev5
+#endif
+
+ifeq ($(DEB_BUILD_ARCH), amd64)
+ CONFIGS += debian-amd64
+endif
+
+#ifeq ($(DEB_BUILD_ARCH), powerpc)
+# CONFIGS += debian-powerpc-603
+#endif
+
+#ifeq ($(DEB_BUILD_ARCH), ppc64)
+# CONFIGS += debian-ppc64
+#endif
+
+#ifeq ($(DEB_BUILD_ARCH), sparc)
+# CONFIGS += debian-sparc-ultrasparc
+#endif
+
+# Use the following to automatically build all optimized configurations
+# available for the build architecture. Use with caution =)
+#CONFIGS += $(subst configs/,,$(wildcard configs/debian-$(DEB_BUILD_ARCH)*))
+
STAMP = $(STAMP_DIR)/$(DEB_BUILD_GNU_TYPE)
BUILD_STAMPS = $(addprefix $(STAMP)-build-, $(CONFIGS))
INSTALL_STAMPS = $(addprefix $(STAMP)-install-, $(CONFIGS))
@@ -50,7 +75,9 @@ $(STAMP_DIR):
$(QUILT_STAMPFN): $(STAMP_DIR)
+
build: $(BUILD_STAMPS)
+
$(STAMP)-build-%: patch
dh_testdir
mkdir -p $(DEB_BUILD_DIR)/$*
@@ -65,9 +92,8 @@ pre-install:
dh_testroot
dh_clean -k --exclude ./Makefile.orig --exclude configs/CVS/Root.bak
rm -rf $(INSTALL_STAMPS)
- dh_installdirs
-install: build pre-install $(INSTALL_STAMPS)
+install: pre-install $(INSTALL_STAMPS)
$(STAMP)-install-%: $(STAMP)-build-%
# Add here commands to install the package into debian/tmp
@@ -77,8 +103,8 @@ $(STAMP)-install-%: $(STAMP)-build-%
clean: unpatch
dh_testdir
dh_testroot
- rm -rf $(DEB_BUILD_DIR) $(STAMP_DIR)
dh_clean --exclude ./Makefile.orig --exclude configs/CVS/Root.bak
+ rm -rf $(DEB_BUILD_DIR) $(STAMP_DIR)
# Build architecture-independent files here.
binary-indep: build install