summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorJulien Cristau <[email protected]>2009-01-31 23:04:06 +0100
committerJulien Cristau <[email protected]>2009-01-31 23:04:06 +0100
commit9a3a20b2b9f893f5b561aa596699d5c72cbe0f4f (patch)
treecafd090e22816a2b376779342dfbc9351a85b626 /debian
parent4672811541f0e7b53c223568644cb938ec22dff4 (diff)
debian/rules: on lpia, only build the i915 and i965 dri drivers
Based on Ubuntu changes, modified to also build swrast.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rwxr-xr-xdebian/rules13
2 files changed, 10 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 46c0f5adc18..bb619bb39ab 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,8 @@ mesa (7.3-2) UNRELEASED; urgency=low
actual releases.
* debian/control: add lpia to the Architecture field for
libgl1-mesa-dri{,-dbg} to match Ubuntu.
+ * debian/rules: on lpia, only build the i915 and i965 dri drivers (based on
+ Ubuntu changes).
-- Julien Cristau <[email protected]> Sat, 31 Jan 2009 22:06:36 +0100
diff --git a/debian/rules b/debian/rules
index 120319e8db4..1583dac02ef 100755
--- a/debian/rules
+++ b/debian/rules
@@ -63,15 +63,18 @@ ifeq ($(DEB_HOST_ARCH_OS), hurd)
DIRECT_RENDERING = --disable-driglx-direct
else
DIRECT_RENDERING = --enable-driglx-direct
+ ifeq ($(DEB_HOST_ARCH), lpia)
+ DRI_DRIVERS += i915 i965
+ else
DRI_DRIVERS += mach64 mga r128 r200 r300 radeon s3v savage tdfx trident
-endif
-
-ifeq ($(DEB_HOST_GNU_CPU), i486)
+ ifeq ($(DEB_HOST_GNU_CPU), i486)
DRI_DRIVERS += i810 i915 i965 sis unichrome
-else ifeq ($(DEB_HOST_GNU_CPU), x86_64)
+ else ifeq ($(DEB_HOST_GNU_CPU), x86_64)
DRI_DRIVERS += i915 i965 sis unichrome
-else ifeq ($(DEB_HOST_ARCH), sparc)
+ else ifeq ($(DEB_HOST_ARCH), sparc)
DRI_DRIVERS += ffb
+ endif
+ endif
endif
confflags-dri = \