summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorJulien Cristau <[email protected]>2010-01-16 16:48:55 +0000
committerJulien Cristau <[email protected]>2010-01-16 16:48:55 +0000
commitb1a881020433f7ebb12cf9791de2081997c0cd49 (patch)
treeefacb2f291a13916823c4f0dd408a589c685ed9a /debian/rules
parent53d395336d87b2e3c30a413bd52c7abc94bd1bd7 (diff)
Rename the build directory to not include DEB_BUILD_GNU_TYPE for no good reason. Thanks, Colin Watson!
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index c9ed8f0d0ac..61210062faa 100755
--- a/debian/rules
+++ b/debian/rules
@@ -22,7 +22,7 @@ DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
DEB_HOST_GNU_CPU ?= $(shell dpkg-architecture -qDEB_HOST_GNU_CPU)
-DEB_BUILD_DIR ?= $(CURDIR)/obj-$(DEB_BUILD_GNU_TYPE)
+DEB_BUILD_DIR ?= $(CURDIR)/build
ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
confflags += --build=$(DEB_HOST_GNU_TYPE)
else
@@ -207,7 +207,7 @@ clean: unpatch
rm -f */config.cache */config.log */config.status
rm -f conftest* */conftest*
rm -rf autom4te.cache */autom4te.cache
- rm -rf obj-*
+ rm -rf build
rm -rf configure config.guess config.sub config.h.in
rm -rf $$(find -name Makefile.in)
rm -rf aclocal.m4 missing depcomp install-sh ltmain.sh