summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorJulien Cristau <[email protected]>2009-09-04 17:22:31 +0200
committerJulien Cristau <[email protected]>2009-09-04 17:22:31 +0200
commitc14446ab00a2e046c0641314e0ce2ee02ed99974 (patch)
treebdc3b6756290cabc2fd8bb6690b4d54b189f91e6 /debian/rules
parent70fd9421ace215d03bce8cb37f14aff0aab1700f (diff)
Don't run install from the various configs in parallel
Hopefully this fixes a bug in the previous debian/rules that could lead to FTBFS. Thanks to Bernhard R. Link for the suggestions.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 4 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 7042fe1c0a2..0d6386f82e3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -187,16 +187,15 @@ $(STAMP)-build-%: configure
touch $@
-install:
+install: build
# Add here commands to install the package into debian/tmp
dh_testdir
dh_testroot
dh_clean -k
dh_installdirs
- $(MAKE) -f debian/rules $(INSTALL_TARGETS)
-
-install-%: $(STAMP)-build-%
- cd $(DEB_BUILD_DIR)/$* && $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
+ set -e; for config in $(CONFIGS); do \
+ $(MAKE) -C $(DEB_BUILD_DIR)/$$config DESTDIR=$(CURDIR)/debian/tmp install; \
+ done
clean: unpatch
dh_testdir