summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorThierry Reding <[email protected]>2006-10-20 12:15:29 +0000
committerThierry Reding <[email protected]>2006-10-20 12:15:29 +0000
commitccffaef60361392807d2fefc1173bd2201febfbc (patch)
tree6fe12286e280487c84cca325b95b6408e451d228 /debian/rules
parentae41f3a3ee89f43fc7987a450739f7757f81d9a6 (diff)
Build architecture-specific static libraries where available.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules19
1 files changed, 9 insertions, 10 deletions
diff --git a/debian/rules b/debian/rules
index 342cd1316e9..02ecb099edc 100755
--- a/debian/rules
+++ b/debian/rules
@@ -26,19 +26,22 @@ DEB_BUILD_DIR ?= $(CURDIR)/obj-$(DEB_BUILD_GNU_TYPE)
export DEB_BUILD_ARCH
-# choose an architecture-specific configuration for building swx11 and GLU if
-# one exists
+# choose an architecture-specific build of swx11 and GLU if a matching
+# configuration exists
ifneq ($(wildcard configs/debian-swx11+glu-$(DEB_BUILD_ARCH)),)
SWX11_GLU_CONFIGS := debian-swx11+glu-$(DEB_BUILD_ARCH)
else
SWX11_GLU_CONFIGS := debian-swx11+glu-any
endif
-# build a static version of swx11 and GLU as well
-SWX11_GLU_CONFIGS += debian-swx11+glu-static
+# same for static builds
+ifneq ($(wildcard configs/debian-swx11+glu-static-$(DEB_BUILD_ARCH)),)
+ SWX11_GLU_CONFIGS += debian-swx11+glu-static-$(DEB_BUILD_ARCH)
+else
+ SWX11_GLU_CONFIGS += debian-swx11+glu-static-any
+endif
-# choose an architecture-specific configuration for building the DRI-enabled
-# libGL if one exists
+# and for the GLX/DRI-enabled libGL
ifneq ($(wildcard configs/debian-dri-$(DEB_BUILD_ARCH)),)
DRI_CONFIGS := debian-dri-$(DEB_BUILD_ARCH)
else
@@ -64,10 +67,6 @@ endif
# SWX11_GLU_CONFIGS += debian-swx11+glu-sparc-ultrasparc
#endif
-# Use the following to automatically build all optimized configurations
-# available for the build architecture. Use with caution =)
-#SWX11_GLU_CONFIGS += $(subst configs/,,$(wildcard configs/debian-swx11+glu-$(DEB_BUILD_ARCH)-*))
-
# build the following configurations by default
CONFIGS = $(SWX11_GLU_CONFIGS) \
$(DRI_CONFIGS) \