summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorTimo Aaltonen <[email protected]>2008-07-03 09:26:46 +0300
committerTimo Aaltonen <[email protected]>2008-07-03 09:26:46 +0300
commitcbaac82c2cf7704203a7eeaa81b02fa6cebba40a (patch)
tree70fbc5d577b234db85611e485ec195724e62c149 /debian/rules
parent9d72de1fb2cc5c2efc79dfe5f275343307287b4a (diff)
Further tweaks to the autoconf stuff. Getting closer but still not there
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules62
1 files changed, 42 insertions, 20 deletions
diff --git a/debian/rules b/debian/rules
index 96513e651b5..b91fb430ea8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -34,14 +34,15 @@ DRI_CONFIGS =
include debian/scripts/choose-configs
# build the following configurations by default
-CONFIGS = osmesa \
+CONFIGS = $(SWX11_GLU_CONFIGS) \
+ dri \
+ osmesa \
osmesa-static \
osmesa16 \
osmesa16-static \
osmesa32 \
osmesa32-static
-
STAMP_DIR = debian/stamp
STAMP = $(STAMP_DIR)/$(DEB_BUILD_GNU_TYPE)
BUILD_STAMPS = $(addprefix $(STAMP)-build-, $(CONFIGS))
@@ -50,31 +51,53 @@ ARCH_INSTALL_STAMPS = $(addprefix $(STAMP)-install-, $(CONFIGS))
QUILT_STAMPFN = $(STAMP_DIR)/patch
include /usr/share/quilt/quilt.make
-confflags-osmesa = --enable-gl-osmesa \
- --with-demos=xdemos
+confflags-common = --disable-glu --disable-glut --disable-glw \
+ CFLAGS="$(CFLAGS)"
-confflags-osmesa-static = --enable-static \
- --with-driver=osmesa \
- --with-demos=
+confflags-dri = --with-demos=xdemos \
+ --libdir=/usr/lib/glx \
+ --with-dri-driverdir=/usr/lib/dri \
+ $(confflags-common)
-confflags-osmesa16 = --with-osmesa-bits=16 \
- --with-driver=osmesa \
- --with-demos=
+confflags-osmesa = --with-driver=osmesa \
+ --with-demos= \
+ $(confflags-common)
-confflags-osmesa16-static = --with-osmesa-bits=16 \
- --with-driver=osmesa \
+confflags-osmesa-static = --with-driver=osmesa \
--enable-static \
- --with-demos=
+ --with-demos= \
+ $(confflags-common)
+
+confflags-osmesa16 = --with-driver=osmesa --with-osmesa-bits=16 \
+ --with-demos= \
+ $(confflags-common)
+
+confflags-osmesa16-static = --with-driver=osmesa --with-osmesa-bits=16 \
+ --enable-static \
+ --with-demos= \
+ $(confflags-common)
+
+confflags-osmesa32 = --with-driver=osmesa --with-osmesa-bits=32 \
+ --with-demos= \
+ $(confflags-common)
+
+confflags-osmesa32-static = --with-driver=osmesa --with-osmesa-bits=32 \
+ --enable-static \
+ --with-demos= \
+ $(confflags-common)
-confflags-osmesa32 = --with-osmesa-bits=32 \
- --with-driver=osmesa \
- --with-demos=
+confflags-swx11+glu = --with-driver=xlib \
+ --with-demos=
-confflags-osmesa32-static = --with-osmesa-bits=32 \
- --with-driver=osmesa \
+confflags-swx11+glu-static = --with-driver=xlib \
--enable-static \
--with-demos=
+confflags-swx11+glu-i386-i686 = --with-driver=xlib \
+ --with-demos= \
+ --libdir=/usr/lib/i686/cmov \
+ CFLAGS="$(CFLAGS) -march=i686"
+
autoreconf:
autoreconf -vfi
@@ -99,8 +122,7 @@ $(STAMP)-build-%:
cd $(DEB_BUILD_DIR)/$* && \
../../configure --prefix=/usr --mandir=\$${prefix}/share/man \
--infodir=\$${prefix}/share/info --sysconfdir=/etc \
- --localstatedir=/var $(confflags) $(confflags-$*) \
- CFLAGS="$(CFLAGS)"
+ --localstatedir=/var $(confflags) $(confflags-$*)
cd $(DEB_BUILD_DIR)/$* && $(MAKE)
touch $@