summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorJulien Cristau <[email protected]>2008-07-05 13:58:30 +0200
committerJulien Cristau <[email protected]>2008-07-05 14:03:57 +0200
commit46ffb3c0b1b493fd33d552771e0dee89939569fb (patch)
treed722a2712a382046e421420e369864f58910d6af /debian/rules
parent4b9b01f0a564b70e01f220081e68aa80893fbb6b (diff)
debian/rules cleanup and fixes
* tell configure which dri drivers we want to build, based on the old configs/debian-dri-default * disable direct rendering for the glx libGL on the hurd * make sure patches are applied before we run autoreconf, and autoreconf runs before all builds
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules32
1 files changed, 26 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index 8a71a8295df..0c716df4423 100755
--- a/debian/rules
+++ b/debian/rules
@@ -16,8 +16,11 @@ ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
endif
DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
+DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
+DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_HOST_GNU_CPU ?= $(shell dpkg-architecture -qDEB_HOST_GNU_CPU)
DEB_BUILD_DIR ?= $(CURDIR)/obj-$(DEB_BUILD_GNU_TYPE)
ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
confflags += --build=$(DEB_HOST_GNU_TYPE)
@@ -28,9 +31,6 @@ endif
export DEB_BUILD_ARCH
# choose which configurations to build
-SWX11_GLU_CONFIGS =
-DRI_CONFIGS =
-
include debian/scripts/choose-configs
# build the following configurations by default
@@ -54,12 +54,32 @@ include /usr/share/quilt/quilt.make
confflags-common = --disable-glu --disable-glut --disable-glw \
CFLAGS="$(CFLAGS)"
+DRI_DRIVERS = swrast
+
+# hurd doesn't do direct rendering
+ifeq ($(DEB_HOST_ARCH_OS), hurd)
+ DIRECT_RENDERING = --disable-driglx-direct
+else
+ DIRECT_RENDERING = --enable-driglx-direct
+ DRI_DRIVERS += mach64 mga r128 r200 r300 radeon s3v savage tdfx trident
+endif
+
+ifeq ($(DEB_HOST_GNU_CPU), i486)
+ DRI_DRIVERS += i810 i915 i965 sis unichrome
+else ifeq ($(DEB_HOST_GNU_CPU), x86_64)
+ DRI_DRIVERS += i915 i965 sis unichrome
+else ifeq ($(DEB_HOST_ARCH), sparc)
+ DRI_DRIVERS += ffb
+endif
+
confflags-dri = \
--with-driver=dri \
+ --with-dri-drivers="$(DRI_DRIVERS)" \
--with-demos=xdemos \
--libdir=/usr/lib/glx \
--with-dri-driverdir=/usr/lib/dri \
--enable-glx-tls \
+ $(DIRECT_RENDERING) \
$(confflags-common)
confflags-osmesa = --with-driver=osmesa \
@@ -106,7 +126,7 @@ confflags-swx11+glu-i386-i686 = --with-driver=xlib \
--libdir=/usr/lib/i686/cmov \
CFLAGS="$(CFLAGS) -march=i686"
-autoreconf:
+configure: $(QUILT_STAMPFN) configure.ac
autoreconf -vfi
# list the configurations that will built
@@ -119,9 +139,9 @@ $(STAMP_DIR):
$(QUILT_STAMPFN): $(STAMP_DIR)
-build: patch autoreconf $(BUILD_STAMPS)
+build: configs $(BUILD_STAMPS)
-$(STAMP)-build-%:
+$(STAMP)-build-%: configure
dh_testdir
mkdir -p $(DEB_BUILD_DIR)/$*