summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorJulien Cristau <[email protected]>2008-08-04 12:49:03 +0200
committerJulien Cristau <[email protected]>2008-08-04 12:49:03 +0200
commit332dcfb60b9153ce956b05ce24f0edfe1ed42ff3 (patch)
tree84ea2688590566418c819a04f1cd0d90819aaf75 /debian/rules
parenta8dde163dc3032515cf18c33bca3cb223ef218b9 (diff)
Add parallel build support.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 6 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index f7a35d2f044..370df33db96 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,13 +6,14 @@
#export DH_VERBOSE=1
CFLAGS = -Wall -g
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
CFLAGS += -O0
else
CFLAGS += -O2
endif
-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
- INSTALL_PROGRAM += -s
+ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+ NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+ MAKEFLAGS += -j$(NUMJOBS)
endif
DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
@@ -180,9 +181,9 @@ pre-install:
dh_clean -k
rm -rf $(ARCH_INSTALL_STAMPS)
-install: pre-install $(ARCH_INSTALL_STAMPS)
+install: $(ARCH_INSTALL_STAMPS)
-$(STAMP)-install-%: $(STAMP)-build-%
+$(STAMP)-install-%: $(STAMP)-build-% pre-install
# Add here commands to install the package into debian/tmp
dh_installdirs