aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJonathan Gray <[email protected]>2014-09-10 16:11:25 +1000
committerTom Stellard <[email protected]>2014-09-10 08:35:11 -0700
commitcdb353539c259d5c5137394f6a7b4dafef9a40da (patch)
tree1d3255aac4f1c1b41c0ea76255d3fa3930a27636 /configure.ac
parentd64ca0a76524222257275f4da5d296e1178ee5b6 (diff)
configure.ac: unbreak the build with non gnu grep
181581280bd430d122d416e308c1de82db82da04 changed the way the llvm-config version is read from sed to grep and introduced a requirement for gnu grep extension that treats BREs as EREs. Avoid this by calling egrep instead of grep which should be able to handle EREs everywhere. This allows Mesa to build on OpenBSD again. Reviewed-by: Tom Stellard <[email protected]> Signed-off-by: Jonathan Gray <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 29cf32e021f..12f914e0f0a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1695,7 +1695,7 @@ if test "x$enable_gallium_llvm" = xyes; then
fi
if test "x$LLVM_CONFIG" != xno; then
- LLVM_VERSION=`$LLVM_CONFIG --version | grep -o '^[[0-9.]]\+'`
+ LLVM_VERSION=`$LLVM_CONFIG --version | egrep -o '^[[0-9.]]+'`
LLVM_LDFLAGS=`$LLVM_CONFIG --ldflags`
LLVM_BINDIR=`$LLVM_CONFIG --bindir`
LLVM_CPPFLAGS=`strip_unwanted_llvm_flags "$LLVM_CONFIG --cppflags"`