aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTom Stellard <[email protected]>2014-02-04 11:54:38 -0500
committerTom Stellard <[email protected]>2014-02-19 14:35:49 -0500
commita4c734297f890eb7034793428ee20c28eaad5a69 (patch)
tree3637e00865a3a9d33260ec40cfc72ee7195189ca /configure.ac
parent8928d7860a6b14ec57c3a600bc429e4563990ead (diff)
configure: Use LLVM shared libraries by default
Linking with LLVM static libraries is easily broken by changes to the llvm-config program or when LLVM adds, removes, or changes library components. Keeping up with these changes requires a lot of maintanence effort to keep the build working on the master and stable branches. Also, because of issues in the past LLVM static libraries, the release manager is currently configuring with --with-llvm-shared-libs when checking the build before release. Enabling shared libraries by default would allow the release manager to run ./configure with no arguments, and be reasonably confident that the build would succeed. Acked-by: Emil Velikov <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 8390d27b585..58ecd6cc182 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1498,11 +1498,11 @@ AC_ARG_ENABLE([gallium-llvm],
[enable_gallium_llvm="$enableval"],
[enable_gallium_llvm=auto])
-AC_ARG_WITH([llvm-shared-libs],
- [AS_HELP_STRING([--with-llvm-shared-libs],
- [link with LLVM shared libraries @<:@default=disabled@:>@])],
+AC_ARG_ENABLE([llvm-shared-libs],
+ [AS_HELP_STRING([--enable-llvm-shared-libs],
+ [link with LLVM shared libraries @<:@default=enabled@:>@])],
[],
- [with_llvm_shared_libs=no])
+ [with_llvm_shared_libs=yes])
AC_ARG_WITH([llvm-prefix],
[AS_HELP_STRING([--with-llvm-prefix],