aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJon TURNEY <[email protected]>2014-08-08 20:13:18 +0100
committerJon TURNEY <[email protected]>2014-08-09 11:18:31 +0100
commita2e1dc0cce3f5c4b94123a5fd4de42ecc988ab14 (patch)
treedbb3e0a44556224cecf637c60c5757d6ddfba3a8 /configure.ac
parent7b4b60b7e501964b689abbd31c77537ff798e6bd (diff)
configure.ac: Use LIBS rather than LDFLAGS to add -ldl to dladdr check
ec8ebff "Check for dladdr()" erroneously uses LDFLAGS rather than LIBS to add -ldl to the dladdr check. Replace the workaround in 39a4cc4 of explicitly checking in libdl, with a more correct approach of using LIBS. Signed-off-by: Jon TURNEY <[email protected]> Reviewed-by: Emil Velikov <[email protected]> Tested-by: Pali Rohár <[email protected]> Cc: "10.2" <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 818536c04a2..e8dd502977c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -535,9 +535,10 @@ AC_CHECK_FUNC([dlopen], [DEFINES="$DEFINES -DHAVE_DLOPEN"],
AC_SUBST([DLOPEN_LIBS])
dnl Check if that library also has dladdr
-AC_CHECK_FUNC([dladdr], [DEFINES="$DEFINES -DHAVE_DLADDR"],
- [AC_CHECK_LIB([dl], [dladdr],
- [DEFINES="$DEFINES -DHAVE_DLADDR"])])
+save_LIBS="$LIBS"
+LIBS="$LIBS $DLOPEN_LIBS"
+AC_CHECK_FUNCS([dladdr])
+LIBS="$save_LIBS"
case "$host_os" in
darwin*|mingw*)