aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Hellstrom <[email protected]>2011-06-15 10:46:24 +0200
committerThomas Hellstrom <[email protected]>2011-06-15 11:06:16 +0200
commit9f2f5b3d7fd70663b98da5d302fcdfd5bc93db05 (patch)
tree812329e0744641c22b75c22dd5ccd67c8d0b8d4e /configure.ac
parent40aec11b7569fcdd2d884629b172af3db3fbaf1d (diff)
st/xa: Initial import of the xa state-tracker and the xa-vmwgfx target.
See the file src/gallium/state_trackers/xa/README for more info. Signed-off-by: Thomas Hellstrom <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 9 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 69513c1c4e2..a99a4e25f74 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1559,6 +1559,9 @@ yes)
fi
have_st_vega="yes"
;;
+ xa)
+ HAVE_ST_XA="yes"
+ ;;
esac
if test -n "$tracker"; then
@@ -1730,7 +1733,8 @@ dnl
dnl Gallium helper functions
dnl
gallium_check_st() {
- if test "x$HAVE_ST_DRI" = xyes || test "x$HAVE_ST_XORG" = xyes; then
+ if test "x$HAVE_ST_DRI" = xyes || test "x$HAVE_ST_XORG" = xyes ||
+ test "x$HAVE_ST_XA" = xyes; then
GALLIUM_WINSYS_DIRS="$GALLIUM_WINSYS_DIRS $1"
fi
if test "x$HAVE_ST_DRI" = xyes && test "x$2" != x; then
@@ -1739,6 +1743,9 @@ gallium_check_st() {
if test "x$HAVE_ST_XORG" = xyes && test "x$3" != x; then
GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS $3"
fi
+ if test "x$HAVE_ST_XA" = xyes && test "x$4" != x; then
+ GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS $4"
+ fi
}
gallium_require_llvm() {
@@ -1749,7 +1756,6 @@ gallium_require_llvm() {
fi
}
-
dnl
dnl Gallium SVGA configuration
dnl
@@ -1760,7 +1766,7 @@ AC_ARG_ENABLE([gallium-svga],
[enable_gallium_svga=auto])
if test "x$enable_gallium_svga" = xyes; then
GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS svga"
- gallium_check_st "svga/drm" "dri-vmwgfx" "xorg-vmwgfx"
+ gallium_check_st "svga/drm" "dri-vmwgfx" "xorg-vmwgfx" "xa-vmwgfx"
elif test "x$enable_gallium_svga" = xauto; then
GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS svga"
fi