aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCyril Brulebois <[email protected]>2011-06-15 15:50:02 +0200
committerMarek Olšák <[email protected]>2011-06-19 21:15:55 +0200
commit9ba2907f2ed893da3da1345647e34a597dd6ed07 (patch)
treede013c7d420400568cd95494db6a26434fe7c953 /configure.ac
parent0c7c5b68766a0d1d4da870fab0bcfd79fed1ed56 (diff)
configure.ac: Avoid running llvm-config when it hadn't been checked for.
If --disable-gallium is passed, llvm-config isn't checked for, so mark it explicitly as absent, through LLVM_CONFIG=no. Passing --disable-gallium would result in: | ../configure: line 9739: --version: command not found | ../configure: line 9740: --cppflags: command not found | ../configure: line 9741: --libs: command not found | ../configure: line 9743: --ldflags: command not found With this commit, one gets that instead: | configure: error: LLVM is required to build Gallium R300 on x86 and x86_64 Signed-off-by: Cyril Brulebois <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b2a0f66c68b..871b16e1ec7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1511,6 +1511,8 @@ dnl
if test "x$with_gallium_drivers" != x; then
SRC_DIRS="$SRC_DIRS gallium gallium/winsys gallium/targets"
AC_PATH_PROG([LLVM_CONFIG], [llvm-config], [no])
+else
+ LLVM_CONFIG=no
fi
AC_SUBST([LLVM_CFLAGS])