summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2012-06-11 10:49:38 -0700
committerEric Anholt <[email protected]>2012-06-21 10:07:38 -0700
commit9ff2709ca571dcfe2f80746e638ad9d0687031fa (patch)
treeefdacd55640e5c7a98e5ac14270fb1bb2dc8dd17 /configure.ac
parent95836b46e77abfe5411922eb7cf71a18c028f42a (diff)
automake: Directly generate configs/current instead of symlinking from it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 1 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 3a930d88c39..a927f7f8d8b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2142,7 +2142,7 @@ CFLAGS="$CFLAGS $USER_CFLAGS"
CXXFLAGS="$CXXFLAGS $USER_CXXFLAGS"
dnl Substitute the config
-AC_CONFIG_FILES([configs/autoconf
+AC_CONFIG_FILES([configs/current
Makefile
src/Makefile
src/gallium/auxiliary/pipe-loader/Makefile
@@ -2183,14 +2183,6 @@ AC_CONFIG_FILES([configs/autoconf
src/mesa/drivers/dri/radeon/Makefile
src/mesa/drivers/dri/swrast/Makefile])
-dnl Replace the configs/current symlink
-AC_CONFIG_COMMANDS([configs],[
-if test -f configs/current || test -L configs/current; then
- rm -f configs/current
-fi
-ln -s autoconf configs/current
-])
-
dnl Sort the dirs alphabetically
GALLIUM_TARGET_DIRS=`echo $GALLIUM_TARGET_DIRS|tr " " "\n"|sort -u|tr "\n" " "`
GALLIUM_WINSYS_DIRS=`echo $GALLIUM_WINSYS_DIRS|tr " " "\n"|sort -u|tr "\n" " "`