summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2017-06-01 15:06:57 +0100
committerEric Engestrom <[email protected]>2017-06-01 16:56:57 +0100
commit845d07978f8eef9b87b952c430edcb8c2b50b1b5 (patch)
treefa21ef84e13703019d6a0df5b44de6b5346cd64d /configure.ac
parentadadadc151fa8232ecd78649a10496661b98e40d (diff)
configure.ac: simplify --enable-libunwind=auto check
Signed-off-by: Eric Engestrom <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 2 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index b57be07e24a..5caf316089a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1066,16 +1066,12 @@ AC_SUBST([LLVM_INCLUDEDIR])
dnl
dnl libunwind
dnl
+PKG_CHECK_EXISTS(libunwind, [HAVE_LIBUNWIND=yes], [HAVE_LIBUNWIND=no])
AC_ARG_ENABLE([libunwind],
[AS_HELP_STRING([--enable-libunwind],
[Use libunwind for backtracing (default: auto)])],
[LIBUNWIND="$enableval"],
- [LIBUNWIND="auto"])
-
-PKG_CHECK_EXISTS(libunwind, [HAVE_LIBUNWIND=yes], [HAVE_LIBUNWIND=no])
-if test "x$LIBUNWIND" = "xauto"; then
- LIBUNWIND="$HAVE_LIBUNWIND"
-fi
+ [LIBUNWIND="$HAVE_LIBUNWIND"])
if test "x$LIBUNWIND" = "xyes"; then
PKG_CHECK_MODULES(LIBUNWIND, libunwind)