summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2017-05-03 15:57:31 +0100
committerEmil Velikov <[email protected]>2017-05-19 19:44:12 +0100
commit8212fc95b59d0dd3cae1fe11359e0fa96d75e1bc (patch)
tree02e30b48f2a0a2380b971c5bb8b52d9161250bd7 /configure.ac
parentf353f844a08c78f2aa225165c05dae31f5700845 (diff)
configure: error out when building GLX w/o the X11 platform
Building EGL/Vulkan/other without X11, while GLX is enabled is confusing and misleading. In practise anyone aiming at the former will also disable GLX. The inverse (some examples below) should still work: ./configure --disable-glx --with-platforms=x11 --with-vulkan-drivers=intel ./configure --disable-glx --with-platforms=x11 --enable-egl Keep in mind that the X11 platform is enabled, by default. Cc: <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 56521127b4c..e6dcea73293 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1719,6 +1719,12 @@ for plat in $platforms; do
esac
done
+if test "x$enable_glx" != xno; then
+ if ! echo "$platforms" | grep -q 'x11'; then
+ AC_MSG_ERROR([Building without the x11 platform as GLX is enabled, is not supported])
+ fi
+fi
+
AM_CONDITIONAL(HAVE_PLATFORM_X11, echo "$platforms" | grep -q 'x11')
AM_CONDITIONAL(HAVE_PLATFORM_WAYLAND, echo "$platforms" | grep -q 'wayland')
AM_CONDITIONAL(HAVE_PLATFORM_DRM, echo "$platforms" | grep -q 'drm')