summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2017-02-07 13:10:34 +0000
committerEmil Velikov <[email protected]>2017-02-13 10:09:45 +0000
commit6ffddba33bdd00b1f5605606c1f76eea17f524ef (patch)
tree5dbd95789f9483991229b93011f1c5cb9e69f1c2 /configure.ac
parent0cbde643eb29c8bf19eb8551ac8e821f7f733212 (diff)
configure.ac: do not use deprecated macros - AC_HELP_STRING AC_ERROR
Replace with AS_HELP_STRING and AC_MSG_ERROR respectively, as spotted by autoupdate. Note that the suggested AC_CANONICAL_SYSTEM > AC_CANONICAL_TARGET change is not addressed here since that requires very extensive testing. Signed-off-by: Emil Velikov <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b4ea40ff865..39da5b4fc85 100644
--- a/configure.ac
+++ b/configure.ac
@@ -442,7 +442,7 @@ int main () {
CFLAGS=$save_CFLAGS
AC_ARG_ENABLE(pwr8,
- [AC_HELP_STRING([--disable-pwr8-inst],
+ [AS_HELP_STRING([--disable-pwr8-inst],
[disable POWER8-specific instructions])],
[enable_pwr8=$enableval], [enable_pwr8=auto])
@@ -2379,7 +2379,7 @@ fi
dnl We need to validate some needed dependencies for renderonly drivers.
if test "x$HAVE_GALLIUM_ETNAVIV" != xyes -a "x$HAVE_GALLIUM_IMX" = xyes ; then
- AC_ERROR([Building with imx requires etnaviv])
+ AC_MSG_ERROR([Building with imx requires etnaviv])
fi
dnl