summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGert Wollny <[email protected]>2018-12-16 12:23:52 +0100
committerMatt Turner <[email protected]>2019-01-16 09:52:42 -0800
commite68777c87ceed02ab199b32f941778c3cf97c794 (patch)
tree190d7cb7643c4934a8b031c64022b3d5f0e49ec7 /configure.ac
parent431e9abaaba6386aa7fbc1ec0e2566a3f8999f5d (diff)
autotools: Deprecate the use of autotools
Since Meson will eventually be the only build system deprecate autotools now. It can still be used by invoking configure with the flag --enable-autotools NAKed-by: Ilia Mirkin <[email protected]> Acked-by: Eric Engestrom <[email protected]> Acked-by: Kenneth Graunke <[email protected]> Acked-by: Lionel Landwerlin <[email protected]> Acked-by: Rob Clark <[email protected]> Acked-by: Jason Ekstrand <[email protected]> Acked-by: Marek Olšák <[email protected]> Acked-by: Kristian H. Kristensen <[email protected]> Reviewed-by: Christian Gmeiner <[email protected]> Reviewed-by: Matt Turner <[email protected]> Reviewed-by: Eric Anholt <[email protected]> Signed-off-by: Gert Wollny <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e4d20054d5f..c7473d77eff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -52,6 +52,19 @@ mingw*)
;;
esac
+AC_ARG_ENABLE(autotools,
+ [AS_HELP_STRING([--enable-autotools],
+ [Enable the use of this autotools based build configuration])],
+ [enable_autotools=$enableval], [enable_autotools=no])
+
+if test "x$enable_autotools" != "xyes" ; then
+ AC_MSG_ERROR([the autotools build system has been deprecated in favour of
+ meson and will be removed eventually. For instructions on how to use meson
+ see https://www.mesa3d.org/meson.html.
+ If you still want to use the autotools build, then add --enable-autotools
+ to the configure command line.])
+fi
+
# Support silent build rules, requires at least automake-1.11. Disable
# by either passing --disable-silent-rules to configure or passing V=1
# to make