summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJason Ekstrand <[email protected]>2015-09-01 15:16:06 -0700
committerJason Ekstrand <[email protected]>2015-09-01 15:16:06 -0700
commitbe0a4da6a571dc82dd491005c2cb01d5a3b09061 (patch)
tree1a1141b066b75ed6b7ab5a39f1081843113dfb8b /configure.ac
parent362ab2d78880288a92682ffcd56942461df00245 (diff)
vk/meta: Use SPIR-V for shaders
We are also now using glslc for compiling the Vulkan driver like we do in curcible.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0c496136d3d..5828885e92a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -99,6 +99,7 @@ AM_PROG_CC_C_O
AM_PROG_AS
AX_CHECK_GNU_MAKE
AC_CHECK_PROGS([PYTHON2], [python2 python])
+AC_CHECK_PROGS([PYTHON3], [python3])
AC_PROG_SED
AC_PROG_MKDIR_P
@@ -1523,6 +1524,10 @@ AC_SUBST([GBM_PC_LIB_PRIV])
AM_CONDITIONAL(HAVE_VULKAN, true)
+AC_ARG_VAR([GLSLC], [Path to the glslc executable])
+AC_CHECK_PROGS([GLSLC], [glslc])
+AC_SUBST([GLSLC])
+
dnl
dnl EGL configuration
dnl
@@ -2533,6 +2538,7 @@ if test "x$MESA_LLVM" = x1; then
echo ""
fi
echo " PYTHON2: $PYTHON2"
+echo " PYTHON3: $PYTHON3"
echo ""
echo " Run '${MAKE-make}' to build Mesa"