summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Romanick <[email protected]>2012-08-01 14:51:37 -0700
committerIan Romanick <[email protected]>2012-08-08 10:06:26 -0700
commit9f7b3d171306ed2ae588e1a4145c5a364cf986ff (patch)
treecc6faef6719967858d562ad261db10f89fc30a89 /configure.ac
parent5602f0f955f370735d4487003bcfb5eb08a6f946 (diff)
Make shared-glapi the default
You can't practically have desktop OpenGL and OpenGL ES on the same system without this. The benefits of not having it (e.g., a more compact dispatch table) are irrelevant. v2: Don't mark shared-glapi as experimental. Review suggestion by Chad. Signed-off-by: Ian Romanick <[email protected]> Reviewed-by: Chad Versace <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ce5714bbd6d..89686b47fcf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -689,9 +689,9 @@ AC_SUBST([API_DEFINES])
AC_ARG_ENABLE([shared-glapi],
[AS_HELP_STRING([--enable-shared-glapi],
- [EXPERIMENTAL. Enable shared glapi for OpenGL @<:@default=no@:>@])],
+ [Enable shared glapi for OpenGL @<:@default=yes@:>@])],
[enable_shared_glapi="$enableval"],
- [enable_shared_glapi=no])
+ [enable_shared_glapi=yes])
SHARED_GLAPI="0"
if test "x$enable_shared_glapi" = xyes; then