summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJose Fonseca <[email protected]>2015-05-29 11:58:58 +0100
committerJose Fonseca <[email protected]>2015-05-29 12:14:34 +0100
commit9119cd7d2c959e437c40c86f214d08dc198bfa69 (patch)
tree7e49010c3c53738a8704e4e494e77f459a47cf12 /configure.ac
parent0db4ef9df152da1d0f3601bbccc68ac1c94d4a3b (diff)
configure.ac: Don't bother checking whether LLVM's MCJIT component is available.
Now that we require LLVM 3.3, MCJIT is guaranteed to be available. Trvial.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 84b404eb8b2..e49473b0f7e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1921,10 +1921,7 @@ if test "x$enable_gallium_llvm" = xyes; then
AC_MSG_ERROR([LLVM $LLVM_REQUIRED_VERSION_MAJOR.$LLVM_REQUIRED_VERSION_MINOR or newer is required])
fi
- LLVM_COMPONENTS="engine bitwriter"
- if $LLVM_CONFIG --components | grep -qw 'mcjit'; then
- LLVM_COMPONENTS="${LLVM_COMPONENTS} mcjit"
- fi
+ LLVM_COMPONENTS="engine bitwriter mcjit"
if test "x$enable_opencl" = xyes; then
llvm_check_version_for "3" "5" "0" "opencl"