summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Airlie <[email protected]>2014-01-28 15:52:13 +1000
committerDave Airlie <[email protected]>2014-01-28 21:51:21 +0000
commitfaee376869734e0d41209e8985084a4380190652 (patch)
tree3734fa1957665d60955383f3db4a9ada6545ea3c /configure.ac
parentdc2f94bc786768329973403248820a2e5249f102 (diff)
loader: fix running with --disable-egl builds
I sometimes build without EGL just for speed purposes, however it no longer finds my drivers when I do due to the HAVE_LIBUDEV defines being wrong. Signed-off-by: Dave Airlie <[email protected]> Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index d266d96b674..ba158e8accf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -867,6 +867,10 @@ xyesno)
;;
esac
+if test "$have_libudev" = yes; then
+ DEFINES="$DEFINES -DHAVE_LIBUDEV"
+fi
+
# This is outside the case (above) so that it is invoked even for non-GLX
# builds.
AM_CONDITIONAL(HAVE_XF86VIDMODE, test "x$HAVE_XF86VIDMODE" = xyes)
@@ -1203,9 +1207,6 @@ if test "x$enable_egl" = xyes; then
if test "$enable_static" != yes; then
# build egl_glx when libGL is built
- if test "$have_libudev" = yes; then
- DEFINES="$DEFINES -DHAVE_LIBUDEV"
- fi
if test "x$enable_dri" = xyes; then
HAVE_EGL_DRIVER_DRI2=1