summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2018-05-09 16:32:12 -0700
committerMatt Turner <[email protected]>2018-05-09 16:38:47 -0700
commit00979402230e659fff57dec612f60987665157fa (patch)
tree08e67c04d48f91e3ec5ac9da1b92a7d5d3e40474 /configure.ac
parent0ab266dc1ba10ec13601e3bdb5b949e610eca5de (diff)
configure.ac: Check for grep with AC_PROG_GREP
Perhaps with a new version of autoconf, I began seeing: | checking the name lister (/usr/bin/nm -B) interface... ./configure: line 6973: External.*some_variable: command not found | BSD nm This is because AC_PROG_NM expands to ... if $GREP 'External.*some_variable' conftest.out > /dev/null; then lt_cv_nm_interface="MS dumpbin" fi ... I'm not sure if it's a bug in AC_PROG_NM that it doesn't call AC_PROG_GREP, but it's easy enough for us to do it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c0fbfe94135..4bb89607e2d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -119,6 +119,7 @@ dnl other CC/CXX flags related help
AC_ARG_VAR([CXX11_CXXFLAGS], [Compiler flag to enable C++11 support (only needed if not
enabled by default and different from -std=c++11)])
AM_PROG_CC_C_O
+AC_PROG_GREP
AC_PROG_NM
AM_PROG_AS
AX_CHECK_GNU_MAKE