summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTom Stellard <[email protected]>2013-09-18 00:36:55 -0700
committerFrancisco Jerez <[email protected]>2013-10-21 10:47:03 -0700
commit07567c17f1eae1feccf160a144fe1563599e5fc0 (patch)
treea88dfdc748a1df1fcd96be400a5300dda2f700e2 /configure.ac
parent9e0b7f76f95dd45c99e95076badba2c8f123c31a (diff)
clover: Prepare the build system for ICD support.
Signed-off-by: Francisco Jerez <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index addbf57d4ca..dfa35b41b12 100644
--- a/configure.ac
+++ b/configure.ac
@@ -593,6 +593,12 @@ AC_ARG_ENABLE([opencl],
@<:@default=no@:>@])],
[],
[enable_opencl=no])
+AC_ARG_ENABLE([opencl_icd],
+ [AS_HELP_STRING([--enable-opencl-icd],
+ [Build an OpenCL ICD library to be loaded by an ICD implementation
+ @<:@default=no@:>@])],
+ [enable_opencl_icd="$enableval"],
+ [enable_opencl_icd=no])
AC_ARG_ENABLE([xlib-glx],
[AS_HELP_STRING([--enable-xlib-glx],
[make GLX library Xlib-based instead of DRI-based @<:@default=disabled@:>@])],
@@ -1356,8 +1362,16 @@ if test "x$enable_opencl" = xyes; then
GALLIUM_STATE_TRACKERS_DIRS="$GALLIUM_STATE_TRACKERS_DIRS clover"
GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS opencl"
enable_gallium_loader=yes
+
+ if test "x$enable_opencl_icd" = xyes; then
+ OPENCL_LIBNAME="MesaOpenCL"
+ else
+ OPENCL_LIBNAME="OpenCL"
+ fi
fi
AM_CONDITIONAL(HAVE_CLOVER, test "x$enable_opencl" = xyes)
+AM_CONDITIONAL(HAVE_CLOVER_ICD, test "x$enable_opencl_icd" = xyes)
+AC_SUBST([OPENCL_LIBNAME])
dnl
dnl Gallium configuration