summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2012-02-03 05:28:14 +0100
committerEric Anholt <[email protected]>2012-02-04 22:04:35 +0100
commitb3c84a80cd7f6d7d6796cb196422c7be44ea47aa (patch)
tree8a754f5956e7170270f74e20fb92063f2e1b3806 /configure.ac
parent84e5f1c635899c657da58ca51d5e841354e9de9c (diff)
mesa: Fix xcb-dri2 link flags leaking into LIBS.
Fixes the build of builtin_compiler on my 32-bit build where xcb-dri2 is in a custom prefix but the custom prefix flags weren't available. It shouldn't have been in LIBS anyway. Reviewed-by: Kenneth Graunke <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 316c715f0c7..e859d4cc6f1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1415,8 +1415,10 @@ if test "x$enable_egl" = xyes; then
EGL_DRIVER_DRI2=dri2
DEFINES="$DEFINES -DHAVE_XCB_DRI2"
# workaround a bug in xcb-dri2 generated by xcb-proto 1.6
+ save_LIBS="$LIBS"
AC_CHECK_LIB(xcb-dri2, xcb_dri2_connect_alignment_pad, [],
[DEFINES="$DEFINES -DXCB_DRI2_CONNECT_DEVICE_NAME_BROKEN"])
+ LIBS="$save_LIBS"
fi
fi