summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2018-08-16 13:59:38 +0100
committerEmil Velikov <[email protected]>2018-10-31 19:15:50 +0000
commit986033a2750c1160a4cef3c8418fc7f9e2b4fb5a (patch)
tree272f346932d8d545e79213feeab07d610fa3dfbd /configure.ac
parent6d7d3dbda531b0bc692ffb479d65527b2138dbf3 (diff)
configure: allow building with python3
Pretty much all of the scripts are python2+3 compatible. Check and allow using python3, while adjusting the PYTHON2 refs. Note: - python3.4 is used as it's the earliest supported version - python2 chosen prior to python3 v2: use python2 by default Cc: Ilia Mirkin <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Acked-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index be9674a0c1d..d782f56205d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -124,9 +124,7 @@ AC_PROG_GREP
AC_PROG_NM
AM_PROG_AS
AX_CHECK_GNU_MAKE
-AM_PATH_PYTHON([2.7],, [:])
-PYTHON2=$PYTHON
-AC_SUBST([PYTHON2])
+AM_PATH_PYTHON([2.7],, [AM_PATH_PYTHON([3.4],, [:])])
AC_PROG_SED
AC_PROG_MKDIR_P
@@ -159,7 +157,7 @@ fi
AX_CHECK_PYTHON_MAKO_MODULE($PYTHON_MAKO_REQUIRED)
-if test "$PYTHON2" = ":"; then
+if test "$PYTHON" = ":"; then
if test ! -f "$srcdir/src/util/format_srgb.c"; then
AC_MSG_ERROR([Python not found - unable to generate sources])
fi
@@ -3376,7 +3374,7 @@ if test "x$enable_llvm" = xyes; then
echo " LLVM_LDFLAGS: $LLVM_LDFLAGS"
echo ""
fi
-echo " PYTHON2: $PYTHON2"
+echo " PYTHON: $PYTHON"
echo ""
echo " Run '${MAKE-make}' to build Mesa"