summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBrian Paul <[email protected]>2011-05-18 07:50:21 -0600
committerBrian Paul <[email protected]>2011-05-18 07:51:33 -0600
commitde1df26b5c11a45f2b1ff2ddc7b8ec764356aa94 (patch)
tree3ad505018f3628b917cd45998c5edf966640d15c /configure.ac
parent3e0bb02358d627e784a2b7041d6e2e23e3dfd2c5 (diff)
mesa: check that flex/bison are installed
Fixes https://bugs.freedesktop.org/show_bug.cgi?id=36651 NOTE: This is a candidate for the 7.10 branch.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a95012c2421..b55473ffec9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,6 +39,12 @@ if test "x$MKDEP" = "x"; then
AC_MSG_ERROR([makedepend is required to build Mesa])
fi
+AC_PATH_PROG([FLEX], [flex])
+test "x$FLEX" = "x" && AC_MSG_ERROR([flex is needed to build Mesa])
+
+AC_PATH_PROG([BISON], [bison])
+test "x$BISON" = "x" && AC_MSG_ERROR([bison is needed to build Mesa])
+
dnl Our fallback install-sh is a symlink to minstall. Use the existing
dnl configuration in that case.
AC_PROG_INSTALL