summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-05-15 22:54:48 +0100
committerEmil Velikov <[email protected]>2014-06-09 22:45:05 +0100
commit93257a56b5b585e79e4ba9f95b38f5bd718e3959 (patch)
treed0c8a6938717887b47ceaccd55819fb7af3b29dc /configure.ac
parent6f9f916b9b042a294813ab0542390846a38739da (diff)
configure: error out when building opencl without LLVM
Cc: Tom Stellard <[email protected]> Cc: "10.1 10.2" <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Tom Stellard <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a12f27ac213..7b0009d63e7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1475,6 +1475,10 @@ if test "x$enable_opencl" = xyes; then
AC_MSG_ERROR([cannot enable OpenCL without Gallium])
fi
+ if test "x$enable_gallium_llvm" != xyes; then
+ AC_MSG_ERROR([cannot enable OpenCL without LLVM])
+ fi
+
if test $GCC_VERSION_MAJOR -lt 4 -o $GCC_VERSION_MAJOR -eq 4 -a $GCC_VERSION_MINOR -lt 7; then
AC_MSG_ERROR([gcc >= 4.7 is required to build clover])
fi