summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2016-12-08 17:58:21 +0000
committerEmil Velikov <[email protected]>2017-01-18 16:01:14 +0000
commit4380a2098b61cfa0dd3855bd63d3c8b70ce25dd5 (patch)
tree8081e92f439e74732837117c5100025a9a4c3382 /configure.ac
parentcb5e799448c959fa9f0d7ea76999ac6f8c0ad88e (diff)
gallium: correctly manage libsensors link flags
We should be using LIBS rather than the LDFLAGS variable. Furthermore try to keep the linking to the final stage, rather than intermetent static library. Cc: Steven Toth <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Nicolai Hähnle <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index b68b51e94a4..450fca161ac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1127,11 +1127,11 @@ AC_ARG_ENABLE([lmsensors],
AM_CONDITIONAL(HAVE_LIBSENSORS, test "x$enable_lmsensors" = xyes)
if test "x$enable_lmsensors" = xyes ; then
DEFINES="${DEFINES} -DHAVE_LIBSENSORS=1"
- LIBSENSORS_LDFLAGS="-lsensors"
+ LIBSENSORS_LIBS="-lsensors"
else
- LIBSENSORS_LDFLAGS=""
+ LIBSENSORS_LIBS=""
fi
-AC_SUBST(LIBSENSORS_LDFLAGS)
+AC_SUBST(LIBSENSORS_LIBS)
case "$host_os" in
linux*)