summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-05-13 01:33:48 +0100
committerEmil Velikov <[email protected]>2014-05-14 23:44:08 +0100
commitf57d092199318f03f6522d0ca616f1f8220b2e6e (patch)
treec4ac04dce808f0c399c4a6682013447bb8dd91a1 /configure.ac
parent8a9f5ecdb116d0449d63f7b94efbfa8b205d826f (diff)
configure: correctly set LD_NO_UNDEFINED
Commit 11623be934f85 was meant to have this hunk, which I accidently dropped during git rebase. Cc: 10.2 <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Julien Cristau <[email protected]> Reviewed-by: Matt Turner <[email protected]> Reviewed-by: Jonathan Gray <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b4a16060fd0..d3e96de976b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -332,6 +332,19 @@ LDFLAGS=$save_LDFLAGS
AC_SUBST([GC_SECTIONS])
dnl
+dnl OpenBSD does not have DT_NEEDED entries for libc by design
+dnl so when these flags are passed to ld via libtool the checks will fail
+dnl
+case "$host_os" in
+openbsd*)
+ LD_NO_UNDEFINED="" ;;
+*)
+ LD_NO_UNDEFINED="-Wl,--no-undefined" ;;
+esac
+
+AC_SUBST([LD_NO_UNDEFINED])
+
+dnl
dnl compatibility symlinks
dnl
case "$host_os" in