summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2016-12-05 19:02:29 +0000
committerEmil Velikov <[email protected]>2016-12-09 19:22:03 +0000
commitd0d21532f9efec7d080db72e4bf2980c0d715a23 (patch)
tree8e9465288e3464ccf9f7ea7c474c9471b1b5c38b /configure.ac
parentb83153e77b08ac82160f6281424878abacd97e31 (diff)
configure: cleanup GLX_USE_TLS handling
Mesa requires ax_pthread_ok = yes, thus we can fold/rewrite the conditional to follow the more common "if test" pattern. No functional change intended. Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 56e91f00784..799f5ebda02 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1710,8 +1710,9 @@ AC_ARG_ENABLE([glx-tls],
[GLX_USE_TLS=yes])
AC_SUBST(GLX_TLS, ${GLX_USE_TLS})
-AS_IF([test "x$GLX_USE_TLS" = xyes -a "x$ax_pthread_ok" = xyes],
- [DEFINES="${DEFINES} -DGLX_USE_TLS"])
+if test "x$GLX_USE_TLS" = xyes; then
+ DEFINES="$DEFINES -DGLX_USE_TLS"
+fi
dnl Read-only text section on x86 hardened platforms
AC_ARG_ENABLE([glx-read-only-text],