summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-05-13 01:33:48 +0100
committerIan Romanick <[email protected]>2014-05-16 23:15:09 -0700
commitb1aa25907a7c32e3c1c29a90348f7eb72fa4e39d (patch)
treeae1f95f9d28e3a4a801917425d4b552c01694af4 /configure.ac
parent5d6e822d03a551138e49dad32732aab00ab2f8fb (diff)
configure: correctly set LD_NO_UNDEFINED
Commit 11623be934f85 was meant to have this hunk, which I accidently dropped during git rebase. Cc: 10.2 <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Julien Cristau <[email protected]> Reviewed-by: Matt Turner <[email protected]> Reviewed-by: Jonathan Gray <[email protected]> (cherry picked from commit f57d092199318f03f6522d0ca616f1f8220b2e6e)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 83073c3fc9d..a85392bda85 100644
--- a/configure.ac
+++ b/configure.ac
@@ -332,6 +332,19 @@ LDFLAGS=$save_LDFLAGS
AC_SUBST([GC_SECTIONS])
dnl
+dnl OpenBSD does not have DT_NEEDED entries for libc by design
+dnl so when these flags are passed to ld via libtool the checks will fail
+dnl
+case "$host_os" in
+openbsd*)
+ LD_NO_UNDEFINED="" ;;
+*)
+ LD_NO_UNDEFINED="-Wl,--no-undefined" ;;
+esac
+
+AC_SUBST([LD_NO_UNDEFINED])
+
+dnl
dnl compatibility symlinks
dnl
case "$host_os" in