summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLouis-Francis Ratté-Boulianne <[email protected]>2017-09-26 23:11:55 -0400
committerDaniel Stone <[email protected]>2018-03-09 17:47:13 +0000
commit61309c2a727d52d543207d6ae79fcb3e68b5cff3 (patch)
tree340bb1ad7a2f801efcaf7a038a825287dbd1c321 /configure.ac
parentc80c08e226033e9e33abdca43e02e7f8c845ae0a (diff)
vulkan/wsi/x11: Return VK_SUBOPTIMAL_KHR for X11
When it is detected that a window could have been flipped but has been copied because of suboptimal format/modifier. The Vulkan client should then re-create the swapchain. Signed-off-by: Louis-Francis Ratté-Boulianne <[email protected]> Reviewed-by: Daniel Stone <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f84903dffeb..1553ce99da4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -94,6 +94,7 @@ XCB_REQUIRED=1.9.3
XCBDRI2_REQUIRED=1.8
XCBDRI3_REQUIRED=1.13
XCBGLX_REQUIRED=1.8.1
+XCBPRESENT_REQUIRED=1.13
XDAMAGE_REQUIRED=1.1
XSHMFENCE_REQUIRED=1.1
XVMC_REQUIRED=1.0.6
@@ -1850,7 +1851,7 @@ fi
if test x"$enable_dri3" = xyes; then
DEFINES="$DEFINES -DHAVE_DRI3"
- dri3_modules="x11-xcb xcb >= $XCB_REQUIRED xcb-dri3 >= $XCBDRI3_REQUIRED xcb-xfixes xcb-present xcb-sync xshmfence >= $XSHMFENCE_REQUIRED"
+ dri3_modules="x11-xcb xcb >= $XCB_REQUIRED xcb-dri3 >= $XCBDRI3_REQUIRED xcb-xfixes xcb-present >= $XCBPRESENT_REQUIRED xcb-sync xshmfence >= $XSHMFENCE_REQUIRED"
PKG_CHECK_MODULES([XCB_DRI3], [$dri3_modules])
fi