summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2017-02-07 16:13:07 +0000
committerEmil Velikov <[email protected]>2017-02-10 11:47:23 +0000
commit514a4944152d3d1a4ac54495388d302e7b7fe0b3 (patch)
tree193523352509147083626257cb0b563103018ebd /configure.ac
parentf64d4d82bd877418a553827cf0ffb9d5742127a8 (diff)
configure.ac: Rename the gallium_require_llvm helper
Drop the gallium prefix since we're about it use it throughout the configure. Note we do want to check for enable_gallium_llvm check since (as explicitly requested) the toggle should mean --enable-llvm. Latter of which to be resolved with later patches. Cc: Dave Airlie <[email protected]> Cc: "17.0" <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Tobias Droste <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 8 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 8fd7b6f001c..9ece9247b97 100644
--- a/configure.ac
+++ b/configure.ac
@@ -967,6 +967,12 @@ llvm_set_environment_variables() {
fi
}
+require_llvm() {
+ if test "x$enable_gallium_llvm" != "xyes"; then
+ AC_MSG_ERROR([--enable-gallium-llvm is required when building $1])
+ fi
+}
+
llvm_check_version_for() {
if test "x$MESA_LLVM" = x0; then
AC_MSG_ERROR([LLVM $1 or newer is required for $2])
@@ -2196,15 +2202,6 @@ AC_ARG_WITH([d3d-libdir],
AC_SUBST([D3D_DRIVER_INSTALL_DIR])
dnl
-dnl Gallium helper functions
-dnl
-gallium_require_llvm() {
- if test "x$enable_gallium_llvm" != "xyes"; then
- AC_MSG_ERROR([--enable-gallium-llvm is required when building $1])
- fi
-}
-
-dnl
dnl r300 doesn't strictly require LLVM, but for performance reasons we
dnl highly recommend LLVM usage. So require it at least on x86 and x86_64
dnl architectures.
@@ -2212,7 +2209,7 @@ dnl
r300_require_llvm() {
case "$host" in *gnux32) return;; esac
case "$host_cpu" in
- i*86|x86_64|amd64) gallium_require_llvm $1
+ i*86|x86_64|amd64) require_llvm $1
;;
esac
}
@@ -2345,7 +2342,7 @@ if test -n "$with_gallium_drivers"; then
;;
xswr)
llvm_check_version_for $LLVM_REQUIRED_SWR "swr"
- gallium_require_llvm "swr"
+ require_llvm "swr"
swr_require_cxx_feature_flags "C++11" "__cplusplus >= 201103L" \
",-std=c++11" \