summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2013-03-09 17:26:43 -0800
committerMatt Turner <[email protected]>2013-07-22 10:48:45 -0700
commit3647efa5c199e4d9c5a3a2d46394642d3736796d (patch)
tree92ec6cf6e9373b5b4ce5be99c79dfb57a8784073 /configure.ac
parent5e4e145025eabfc95e636d6c29da670e375649d0 (diff)
build: Remove unused EGL_PLATFORMS.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 1 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 35f6797eed6..c1f3d508d8b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1423,8 +1423,6 @@ AC_ARG_WITH([egl-platforms],
with_egl_platforms=""
fi])
-EGL_PLATFORMS=""
-
if test "x$with_egl_platforms" != "x" -a "x$enable_egl" != xyes; then
AC_MSG_ERROR([cannot build egl state tracker without EGL library])
fi
@@ -1478,8 +1476,6 @@ else
EGL_NATIVE_PLATFORM="_EGL_INVALID_PLATFORM"
fi
-EGL_PLATFORMS="$egl_platforms"
-
if echo "$egl_platforms" | grep 'x11' >/dev/null 2>&1; then
NEED_WINSYS_XLIB=yes
fi
@@ -1493,7 +1489,6 @@ AM_CONDITIONAL(HAVE_EGL_DRIVER_DRI2, test "x$HAVE_EGL_DRIVER_DRI2" != "x")
AM_CONDITIONAL(HAVE_EGL_DRIVER_GLX, test "x$HAVE_EGL_DRIVER_GLX" != "x")
AC_SUBST([EGL_NATIVE_PLATFORM])
-AC_SUBST([EGL_PLATFORMS])
AC_SUBST([EGL_CFLAGS])
# If we don't have the X11 platform, set this define so we don't try to include
@@ -2184,7 +2179,7 @@ dnl EGL
echo ""
echo " EGL: $enable_egl"
if test "$enable_egl" = yes; then
- echo " EGL platforms: $EGL_PLATFORMS"
+ echo " EGL platforms: $egl_platforms"
egl_drivers=""
if test "x$HAVE_EGL_DRIVER_GLX" != "x"; then