summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2012-01-18 11:27:24 -0800
committerEric Anholt <[email protected]>2012-01-23 11:34:05 -0800
commit36473395f1e7574fc22fd4f5210ad6a8def76d91 (patch)
treee89b94bab67032c30b38e9bf805101ab3e895f8d /configure.ac
parentc25e5300cba7628b58df93ead14ebc3cc32f338c (diff)
autoconf: Fix build of dri symbols test to not manually link expat.
AC_CHECK_LIB has this nasty behavior, like the cflags tests, of automatically putting the tested value into the global LIBS on success. This caused -lexpat to end up in LIBS, but without the --with-expat dir, so my 32-bit build on a 64 system using expat from a custom prefix could only find the system expat and fail to link on the one current consumer of the LIBS variable: the dri driver test link. Reviewed-by: Kenneth Graunke <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c76af5b2401..b15a4bc3994 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1231,8 +1231,10 @@ if test "x$enable_dri" = xyes; then
EXPAT_LIB="-L$withval/$LIB_DIR -lexpat"
])
AC_CHECK_HEADER([expat.h],[],[AC_MSG_ERROR([Expat required for DRI.])])
+ save_LIBS="$LIBS"
AC_CHECK_LIB([expat],[XML_ParserCreate],[],
[AC_MSG_ERROR([Expat required for DRI.])])
+ LIBS="$save_LIBS"
fi
# libdrm is required for all except swrast