summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2017-01-18 13:54:01 +0000
committerEmil Velikov <[email protected]>2017-02-10 11:47:24 +0000
commitfc30992a54dbf4274e8741ebd64f289e06b38096 (patch)
tree54809b347caf13ccd7b75a3d327ae4db61ba0e69 /configure.ac
parent5e9f4a5f3f785d188695cb11437d0d303b2d5c70 (diff)
Revert "configure.ac: Create correct LLVM_VERSION_INT with minor >= 10"
As stated in [1] by the LLVM devs, the new versioning scheme will not deploy any minor version (i.e. it will always be zero). As such the patch should not be needed. This reverts commit 0e9a5be7e74fa2a9bd2a634ef60822bd6600ca1d. [1] http://blog.llvm.org/2016/12/llvms-new-versioning-scheme.html Reviewed-by: Tobias Droste <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 1 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 9f94d8b3ac8..b2065d3fe14 100644
--- a/configure.ac
+++ b/configure.ac
@@ -952,11 +952,7 @@ llvm_set_environment_variables() {
LLVM_VERSION_PATCH=0
fi
- if test "$LLVM_VERSION_MINOR" -lt 10; then
- LLVM_VERSION_INT="${LLVM_VERSION_MAJOR}0${LLVM_VERSION_MINOR}"
- else
- LLVM_VERSION_INT="${LLVM_VERSION_MAJOR}${LLVM_VERSION_MINOR}"
- fi
+ LLVM_VERSION_INT="${LLVM_VERSION_MAJOR}0${LLVM_VERSION_MINOR}"
FOUND_LLVM=yes
else