summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2017-03-02 19:14:24 +0000
committerEmil Velikov <[email protected]>2017-03-13 11:16:30 +0000
commitd1042ef1dcb36f36b93aaa6a62b54955e606fce7 (patch)
treef9a62699b64aa97e01158e0a76e13aa09710e51f /configure.ac
parentc1b5ed853f45b2b5a8114c5a6d3c8e467756a41e (diff)
configure.ac: provide a fall-back define for WAYLAND_SCANNER
In some cases, we can end up calling WAYLAND_SCANNER even when there's no binary. Do follow the other's approach set by AX_PROG_FLEX/BISON and set the variable to : Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Jason Ekstrand <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d64ed2d3e8d..19a9cdd0070 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2106,7 +2106,7 @@ PKG_CHECK_MODULES([WAYLAND_SCANNER], [wayland-scanner],
WAYLAND_SCANNER=`$PKG_CONFIG --variable=wayland_scanner wayland-scanner`,
WAYLAND_SCANNER='')
if test "x$WAYLAND_SCANNER" = x; then
- AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner])
+ AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner], [:])
fi
# Do per-EGL platform setups and checks
@@ -2117,7 +2117,7 @@ for plat in $egl_platforms; do
PKG_CHECK_MODULES([WAYLAND], [wayland-client >= $WAYLAND_REQUIRED wayland-server >= $WAYLAND_REQUIRED])
- if test "x$WAYLAND_SCANNER" = x; then
+ if test "x$WAYLAND_SCANNER" = "x:"; then
AC_MSG_ERROR([wayland-scanner is needed to compile the wayland egl platform])
fi
;;