summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarek Olšák <[email protected]>2016-10-18 23:20:29 +0200
committerMarek Olšák <[email protected]>2016-10-19 23:19:16 +0200
commitbaed5eab82262bf9b76f5e237ecf21605360d0e3 (patch)
tree3a458207be992658db889696d5d122c96d3fd7a8 /configure.ac
parent4650a27ba18a5524ca0a9ea3019c35eb2a9c9f43 (diff)
configure.ac: enable EGL platform DRM if GBM is enabled
since GBM is enabled by default, this is also enabled by default the whitespace changes remove tabs Reviewed-by: Eric Engestrom <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 6f6e388caca..797c2de6163 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2017,9 +2017,13 @@ AC_ARG_WITH([egl-platforms],
"x11,drm" @<:@default=auto@:>@])],
[with_egl_platforms="$withval"],
[if test "x$enable_egl" = xyes; then
- with_egl_platforms="x11"
+ if test "x$enable_gbm" = xyes; then
+ with_egl_platforms="x11,drm"
+ else
+ with_egl_platforms="x11"
+ fi
else
- with_egl_platforms=""
+ with_egl_platforms=""
fi])
if test "x$with_egl_platforms" != "x" -a "x$enable_egl" != xyes; then