summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJonathan Gray <[email protected]>2014-09-06 01:44:41 +1000
committerEmil Velikov <[email protected]>2014-09-09 21:39:00 +0100
commit9f67c26d1b424b8f3d86b5435c8f74d0a81eb86d (patch)
tree5e2d2c5f088ed377c9348e583b432c47e2b42e18 /configure.ac
parent07426ad1029c3505b809dc9eec104007fb623983 (diff)
configure.ac: strip _GNU_SOURCE from llvm-config output
Mesa already defines _GNU_SOURCE for glibc based systems and defining _GNU_SOURCE will break the Mesa build on other systems such as OpenBSD. _GNU_SOURCE only seems to be included in llvm-config output when LLVM is built via autoconf and not when it is built by cmake. Cc: "10.2 10.3" <[email protected]> Signed-off-by: Jonathan Gray <[email protected]> (cherry picked from commit c68073e65f15b0df43bec2df1d7470ed4cddd761)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0622f186806..43200455bdd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1655,6 +1655,7 @@ strip_unwanted_llvm_flags() {
# Use \> (marks the end of the word)
echo `$1` | sed \
-e 's/-DNDEBUG\>//g' \
+ -e 's/-D_GNU_SOURCE\>//g' \
-e 's/-pedantic\>//g' \
-e 's/-Wcovered-switch-default\>//g' \
-e 's/-O.\>//g' \