summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTobias Droste <[email protected]>2016-11-19 02:39:04 +0100
committerEmil Velikov <[email protected]>2016-12-05 14:43:46 +0000
commit9d14a25bee0f1457a82f3e42b3baf3db1806faea (patch)
treeccec158b8362518d31d81d82ff96ef13a0ff9050 /configure.ac
parent19ff3975de6947bb8c6bfddff8e599c737f9185f (diff)
configure.ac: Move llvm_set_environment_variables higher.
This moves the function to get the LLVM environment variables higher in the file. It still needs to be below the "--enable-opencl" because it uses $enable_opencl. It can be called without condition now as it only throws errors if openCL is enabled. v5: HAVE_MESA_LLVM is only used for gallium. Rename it to HAVE_GALLIUM_LLVM. In order to only link LLVM when it is needed, HAVE_GALLIUM_LLVM is only set if "$enable-gallium-llvm" is yes. Signed-off-by: Tobias Droste <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 4 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 1de6b7e905d..3e9972c7e32 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1189,6 +1189,8 @@ AC_ARG_ENABLE([gallium-tests],
[enable_gallium_tests="$enableval"],
[enable_gallium_tests=no])
+llvm_set_environment_variables
+
# Option for Gallium drivers
# Keep this in sync with the --with-gallium-drivers help string default value
@@ -2285,12 +2287,6 @@ if test "x$enable_gallium_llvm" = xauto; then
i*86|x86_64|amd64) enable_gallium_llvm=yes;;
esac
fi
-if test "x$enable_gallium_llvm" = xyes || test "x$HAVE_RADEON_VULKAN" = xyes; then
- llvm_set_environment_variables
-else
- MESA_LLVM=0
- LLVM_VERSION_INT=0
-fi
dnl Directory for XVMC libs
AC_ARG_WITH([xvmc-libdir],
@@ -2626,7 +2622,8 @@ AM_CONDITIONAL(NEED_RADEON_DRM_WINSYS, test "x$HAVE_GALLIUM_R300" = xyes -o \
AM_CONDITIONAL(NEED_WINSYS_XLIB, test "x$enable_glx" = xgallium-xlib)
AM_CONDITIONAL(NEED_RADEON_LLVM, test x$NEED_RADEON_LLVM = xyes)
AM_CONDITIONAL(HAVE_GALLIUM_COMPUTE, test x$enable_opencl = xyes)
-AM_CONDITIONAL(HAVE_MESA_LLVM, test x$MESA_LLVM = x1)
+AM_CONDITIONAL(HAVE_GALLIUM_LLVM, test "x$MESA_LLVM" = x1 -a \
+ "x$enable_gallium_llvm" = xyes)
AM_CONDITIONAL(USE_VC4_SIMULATOR, test x$USE_VC4_SIMULATOR = xyes)
if test "x$USE_VC4_SIMULATOR" = xyes -a "x$HAVE_GALLIUM_ILO" = xyes; then
AC_MSG_ERROR([VC4 simulator on x86 replaces i965 driver build, so ilo must be disabled.])