summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2012-02-05 10:46:13 +0100
committerEric Anholt <[email protected]>2012-02-29 11:52:40 -0800
commit88612029f6ce9d2717220a0ef31bfe71a8c85529 (patch)
treed86254fa4af549ab8850c39d07b929ea6cb82fd2 /configure.ac
parent28d92eff73a0821e7a73b04d3f50e715850dc5e9 (diff)
egl/main: Convert to automake.
The drivers/ walk-through-subdirs makefile is converted as well so I didn't need to keep EGL_DRIVERS_DIRS along with the per-driver HAVE_EGL_DRIVER_WHATEVER. Reviewed-by: Kenneth Graunke <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac42
1 files changed, 32 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index e9f00b34bc3..9cd814dbf51 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1401,14 +1401,13 @@ EGL_CLIENT_APIS=""
if test "x$enable_egl" = xyes; then
SRC_DIRS="$SRC_DIRS egl"
EGL_LIB_DEPS="$DLOPEN_LIBS $SELINUX_LIBS -lpthread"
- EGL_DRIVERS_DIRS=""
AC_CHECK_FUNC(mincore, [DEFINES="$DEFINES -DHAVE_MINCORE"])
if test "$enable_static" != yes; then
# build egl_glx when libGL is built
if test "x$enable_glx" = xyes; then
- EGL_DRIVERS_DIRS="glx"
+ HAVE_EGL_DRIVER_GLX=1
fi
PKG_CHECK_MODULES([LIBUDEV], [libudev > 150],
@@ -1420,10 +1419,8 @@ if test "x$enable_egl" = xyes; then
# build egl_dri2 when xcb-dri2 is available
PKG_CHECK_MODULES([XCB_DRI2], [x11-xcb xcb-dri2 xcb-xfixes],
[have_xcb_dri2=yes],[have_xcb_dri2=no])
-
if test "$have_xcb_dri2" = yes; then
- EGL_DRIVER_DRI2=dri2
- DEFINES="$DEFINES -DHAVE_XCB_DRI2"
+ HAVE_EGL_DRIVER_DRI2=1
# workaround a bug in xcb-dri2 generated by xcb-proto 1.6
save_LIBS="$LIBS"
AC_CHECK_LIB(xcb-dri2, xcb_dri2_connect_alignment_pad, [],
@@ -1432,11 +1429,9 @@ if test "x$enable_egl" = xyes; then
fi
fi
- EGL_DRIVERS_DIRS="$EGL_DRIVERS_DIRS $EGL_DRIVER_DRI2"
fi
fi
AC_SUBST([EGL_LIB_DEPS])
-AC_SUBST([EGL_DRIVERS_DIRS])
dnl
dnl EGL Gallium configuration
@@ -1722,8 +1717,29 @@ for plat in $egl_platforms; do
esac
done
+# libEGL wants to default to the first platform specified in
+# ./configure. parse that here.
+if test "x$egl_platforms" != "x"; then
+ FIRST_PLATFORM_CAPS=`echo $egl_platforms | sed 's| .*||' | tr 'a-z' 'A-Z'`
+ EGL_NATIVE_PLATFORM="_EGL_PLATFORM_$FIRST_PLATFORM_CAPS"
+else
+ EGL_NATIVE_PLATFORM="_EGL_INVALID_PLATFORM"
+fi
+
EGL_PLATFORMS="$egl_platforms"
+
+AM_CONDITIONAL(HAVE_EGL_PLATFORM_X11, echo "$egl_platforms" | grep 'x11' >/dev/null 2>&1)
+AM_CONDITIONAL(HAVE_EGL_PLATFORM_WAYLAND, echo "$egl_platforms" | grep 'wayland' >/dev/null 2>&1)
+AM_CONDITIONAL(HAVE_EGL_PLATFORM_DRM, echo "$egl_platforms" | grep 'drm' >/dev/null 2>&1)
+AM_CONDITIONAL(HAVE_EGL_PLATFORM_FBDEV, echo "$egl_platforms" | grep 'fbdev' >/dev/null 2>&1)
+AM_CONDITIONAL(HAVE_EGL_PLATFORM_NULL, echo "$egl_platforms" | grep 'null' >/dev/null 2>&1)
+
+AM_CONDITIONAL(HAVE_EGL_DRIVER_DRI2, test "x$HAVE_EGL_DRIVER_DRI2" != "x")
+AM_CONDITIONAL(HAVE_EGL_DRIVER_GLX, test "x$HAVE_EGL_DRIVER_GLX" != "x")
+
+AC_SUBST([EGL_NATIVE_PLATFORM])
AC_SUBST([EGL_PLATFORMS])
+AC_SUBST([EGL_CFLAGS])
AC_ARG_WITH([egl-driver-dir],
[AS_HELP_STRING([--with-egl-driver-dir=DIR],
@@ -1935,6 +1951,9 @@ AC_CONFIG_FILES([configs/autoconf
src/gallium/drivers/r300/Makefile
src/gbm/Makefile
src/gbm/main/gbm.pc
+ src/egl/drivers/Makefile
+ src/egl/main/Makefile
+ src/egl/main/egl.pc
src/egl/wayland/Makefile
src/egl/wayland/wayland-egl/Makefile
src/egl/wayland/wayland-egl/wayland-egl.pc
@@ -2023,9 +2042,12 @@ if test "$enable_egl" = yes; then
echo " EGL platforms: $EGL_PLATFORMS"
egl_drivers=""
- for d in $EGL_DRIVERS_DIRS; do
- egl_drivers="$egl_drivers builtin:egl_$d"
- done
+ if test "x$HAVE_EGL_DRIVER_GLX" != "x"; then
+ egl_drivers="$egl_drivers builtin:egl_glx"
+ fi
+ if test "x$HAVE_EGL_DRIVER_DRI2" != "x"; then
+ egl_drivers="$egl_drivers builtin:egl_dri2"
+ fi
if test "x$HAVE_ST_EGL" = xyes; then
echo " EGL drivers: ${egl_drivers} egl_gallium"