summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexandre Demers <[email protected]>2013-01-12 01:21:44 -0500
committerAndreas Boll <[email protected]>2013-01-13 00:13:16 +0100
commit67ef755908375661c2cc1e7a26922682b981dc97 (patch)
tree7103b51703288906f0dcefc1cb52e47f13afff71 /configure.ac
parentac1c2b82385911309860526eb335dcb495f12999 (diff)
configure.ac: Fixing common dri dependency when using dri state tracker
Fixes a regression caused by b587a7595e7aae0809a8e7392e89c39df0c955b1 Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=59261 Reviewed-by: Andreas Boll <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 72df83c0cd6..bde5b057818 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1079,8 +1079,8 @@ if test "x$enable_dri" = xyes; then
LIBS="$save_LIBS"
fi
- # if we are building any dri driver other than swrast ...
- if test -n "$DRI_DIRS" -a x"$DRI_DIRS" != xswrast; then
+ # if we are building any dri driver other than swrast or using the dri state tracker ...
+ if test -n "$DRI_DIRS" -a x"$DRI_DIRS" != xswrast || test "x$enable_dri" = xyes; then
# ... libdrm is required
if test "x$have_libdrm" != xyes; then
AC_MSG_ERROR([DRI drivers requires libdrm >= $LIBDRM_REQUIRED])