summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTobias Droste <[email protected]>2016-11-19 02:39:05 +0100
committerEmil Velikov <[email protected]>2016-12-05 14:43:47 +0000
commit62f4e6f2726c34357e274fcc1ef934f96c498ba2 (patch)
tree1e8e04ff6ac9c86164176a405b3cdeec6fa907ad /configure.ac
parent9d14a25bee0f1457a82f3e42b3baf3db1806faea (diff)
configure.ac: Move oCL LLVM checks to the oCL section
The LLVM checks can be anywhere below line 1161 now. Move the openCL LLVM checks to the section with the other openCL checks. No functional change. Signed-off-by: Tobias Droste <[email protected]> Reviewed-by: Emil Velikov <[email protected]> [Emil Velikov: s/ipos/ipo/, drop "yes" argument from llvm_add_component] Signed-off-by: Emil Velikov <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac41
1 files changed, 19 insertions, 22 deletions
diff --git a/configure.ac b/configure.ac
index 3e9972c7e32..0a82dda7c17 100644
--- a/configure.ac
+++ b/configure.ac
@@ -984,30 +984,8 @@ llvm_set_environment_variables() {
llvm_add_default_components "gallium"
- if test "x$enable_opencl" = xyes; then
- llvm_check_version_for "3" "6" "0" "opencl"
-
- llvm_add_component "all-targets" "opencl"
- llvm_add_component "ipo" "opencl"
- llvm_add_component "linker" "opencl"
- llvm_add_component "instrumentation" "opencl"
- llvm_add_component "irreader" "opencl"
- llvm_add_component "option" "opencl"
- llvm_add_component "objcarcopts" "opencl"
- llvm_add_component "profiledata" "opencl"
- fi
DEFINES="${DEFINES} -DHAVE_LLVM=0x0$LLVM_VERSION_INT -DMESA_LLVM_VERSION_PATCH=$LLVM_VERSION_PATCH"
MESA_LLVM=1
-
- dnl Check for Clang internal headers
- if test "x$enable_opencl" = xyes; then
- if test -z "$CLANG_LIBDIR"; then
- CLANG_LIBDIR=${LLVM_LIBDIR}
- fi
- CLANG_RESOURCE_DIR=$CLANG_LIBDIR/clang/${LLVM_VERSION}
- AS_IF([test ! -f "$CLANG_RESOURCE_DIR/include/stddef.h"],
- [AC_MSG_ERROR([Could not find clang internal header stddef.h in $CLANG_RESOURCE_DIR Use --with-clang-libdir to specify the correct path to the clang libraries.])])
- fi
else
MESA_LLVM=0
LLVM_VERSION_INT=0
@@ -2143,6 +2121,25 @@ if test "x$enable_opencl" = xyes; then
if test "x$have_libelf" != xyes; then
AC_MSG_ERROR([Clover requires libelf])
fi
+
+ llvm_check_version_for "3" "6" "0" "opencl"
+
+ llvm_add_component "all-targets" "opencl"
+ llvm_add_component "linker" "opencl"
+ llvm_add_component "instrumentation" "opencl"
+ llvm_add_component "ipo" "opencl"
+ llvm_add_component "irreader" "opencl"
+ llvm_add_component "option" "opencl"
+ llvm_add_component "objcarcopts" "opencl"
+ llvm_add_component "profiledata" "opencl"
+
+ dnl Check for Clang internal headers
+ if test -z "$CLANG_LIBDIR"; then
+ CLANG_LIBDIR=${LLVM_LIBDIR}
+ fi
+ CLANG_RESOURCE_DIR=$CLANG_LIBDIR/clang/${LLVM_VERSION}
+ AS_IF([test ! -f "$CLANG_RESOURCE_DIR/include/stddef.h"],
+ [AC_MSG_ERROR([Could not find clang internal header stddef.h in $CLANG_RESOURCE_DIR Use --with-clang-libdir to specify the correct path to the clang libraries.])])
fi
AM_CONDITIONAL(HAVE_CLOVER, test "x$enable_opencl" = xyes)
AM_CONDITIONAL(HAVE_CLOVER_ICD, test "x$enable_opencl_icd" = xyes)